Cannot Open Input Files "New" and Windows.h when making new code project and other problems when using work arounds

So I’m having a problem a few others have had. Just for info sakes: I am using Visual Studio 2013 Community Version (the version that downloads from the launcher if you have no C++ IDE installed), Unreal Engine v.4.9.2 and am on a Windows 7 PC.
Problems: When I try to create a fresh C++ project from the engine, I get errors stating that it couldn’t open the include files ‘new’ and ‘windows.h’. (see below)

Running C:/Program Files/Epic
BatteryCollector3 Development Win64
-rocket -editorrecompile -progress -noubtmakefiles @progress push 5% Parsing headers for
BatteryCollector3Editor Running
-LogCmds=“loginit warning, logexit warning, logdatabase error” -rocket
-installed Reflection code generated for BatteryCollector3Editor in
8.6619916 seconds @progress pop Performing 11 actions (4 in parallel)
[2/11] Resource PCLaunch.rc [3/11]
Resource ModuleVersionResource.rc.inl
PCH.BatteryCollector3.h.cpp C:\Program
: fatal error C1083: Cannot open
include file: ‘new’: No such file or
directory C:\Program Files\Epic
: fatal error RC1015: cannot open
include file ‘windows.h’. C:\Program
: fatal error RC1015: cannot open
include file ‘windows.h’.
-------- End Detailed Actions Stats ----------------------------------------------------------- ERROR: UBT ERROR: Failed to produce
Total build time: 30.81 seconds

I have tried this with different types of C++ projects from the engine (3d Shooter and Vehicle) and got the same errors.

I have already completely removed Unreal(engine and launcher) and Visual Studio 2013 Community and reinstalled them with Studio going on first then Unreal.
I have checked and made sure that I have the SDK. I am unable to change my microsoft login/user folder name from first.last format as this is a work computer so if the . is the problem, I’m just screwed. No other special characters are in my name.
I have tried the ‘inherit from project defaults’ fix and that somewhat works but it is more a work around than an actual fix as I will need to do this every time I make a new project. Further, when I add a new C++ Class from within the engine, while it makes the files, I then get an error stating that the entire project will need to be re-compiled before it will reflect it. Further, the output file states there was an error opening input file “delayimp.lib” (see below)

Running C:/Program Files/Epic
BatteryCollector Win64 Development
-editorrecompile “C:/Users/roy.davis/Documents/Unreal
-invalidatemakefilesonly -rocket Invalidating makefiles only in this
run. Recompiling BatteryCollector…
Launching UnrealBuildTool…
[C:/Program Files/Epic
BatteryCollector -ModuleWithSuffix
BatteryCollector 8147 Win64
Development -editorrecompile
-canskiplink “C:/Users/roy.davis/Documents/Unreal
-rocket -rocket] CompilerResultsLog: New page: Compilation - Oct 20, 2015,
11:08:27 AM CompilerResultsLog: Info
Creating makefile for hot reloading
BatteryCollector (no existing
makefile) CompilerResultsLog: Info
Compiling game modules for hot reload
CompilerResultsLog: Info Parsing
headers for BatteryCollectorEditor
CompilerResultsLog: Info Running
-LogCmds=“loginit warning, logexit warning, logdatabase error” -rocket
-installed CompilerResultsLog: Info Reflection code generated for
BatteryCollectorEditor in 12.1695956
seconds CompilerResultsLog: Info
Performing 3 actions (4 in parallel)
CompilerResultsLog: Info
Collection.cpp CompilerResultsLog:
Info BatteryCollector.generated.cpp
CompilerResultsLog: Info [3/3] Link
CompilerResultsLog:Error: Error LINK :
fatal error LNK1181: cannot open input
file ‘delayimp.lib’
CompilerResultsLog: Info -------- End
Detailed Actions Stats
----------------------------------------------------------- CompilerResultsLog: Info ERROR: UBT
ERROR: Failed to produce item:
CompilerResultsLog: Info Total build
time: 87.41 seconds LogMainFrame:
MainFrame: Module compiling took
87.862 seconds Warning: HotReload failed, recompile failed Warning:
RebindPackages failed because the
compiler could not be started.
LogHotReload: New module detected:
LogHotReload: Starting Hot-Reload from
IDE LogModuleManager:Warning:
ModuleManager: Unable to load module
‘BatteryCollector’ because the file
was not found. Warning: HotReload
failed, reload failed
LogContentBrowser: Native class
hierarchy populated in 0.0181 seconds.
Added 1870 classes and 337 folders.
LogHttp:Warning: Timeout processing
Http request. 00000000077A8500

I get that, even with everything working well, I would probably still have to shut down the engine and recompile things if I made massive changes but seems like I shouldn’t have to do it for every single thing which I have to at this moment. I am about to try using Visual Studio 2013 For Desktop just to be sure but if anyone could give any other suggestions, it would greatly be appreciated.

Update: 10/22/2015 1:55PM EST
Installed Visual Studio 2013 Express For Desktop on my computer after removing Community and rebooting. Tried making a new file but received a new error that the compiler couldn’t find “mspdb120.dll”. After some searching, I found that the solutions were to try deleting the containing folder in the Visual Studio installation location or reinstalling my entire OS. Removed the folder and did a repair but the file was still missing. Copied it from another location and this got me to the errors of the compiler not being able to open the header files “New” and “Windows.h”. Once again I did the “Inherit” work around in Visual Studio and tried compiling the project from there after closing Unreal. Received new errors now as follows:

1>------ Build started: Project:
MyProject2, Configuration:
Development_Editor x64 ------ 1>
Performing full C++ include scan
(building a new target) 1> Creating
makefile for MyProject2Editor (no
existing makefile) 1> Performing 8
actions (4 in parallel) 1> [3/8]
Resource ModuleVersionResource.rc.inl
1> [2/8] Resource PCLaunch.rc 1>
PCH.MyProject2.h.cpp 1>
MyProject2.cpp 1>
MyProject2Character.cpp 1>
MyProject2GameMode.cpp 1>
MyProject2.generated.cpp 1> [8/8]
Link UE4Editor-MyProject2.dll 1>
Creating library
and object
1>LINK : fatal error LNK1158: cannot
run ‘cvtres.exe’ 1> -------- End
Detailed Actions Stats
----------------------------------------------------------- 1>ERROR : UBT error : Failed to
produce item:
1> Total build time: 41.11 seconds
1>C:\Program Files
error MSB3073: The command
““C:\Program Files\Epic
Games\4.9\Engine\Build\BatchFiles\Build.bat” MyProject2Editor Win64 Development
-rocket -waitmutex” exited with code -1.
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped

OK! So, after a bit more trial and error I actually got things to work. Here’s what I did.

Had my system administrator come to my comp and log in as administrator. I’m suppose to be an admin but it’s wonky and I’m like… sub admin… anyway. From there, we completely removed ALL VERSIONS OF VISUAL STUDIO. Not those redistributable files, just the programs. I had 2003 C++ Express and 2008 on my comp along with 2013.

After the uninstalls, rebooted into my profile and re-installed Visual Studio 2013 Express For Desktop. Once done, I opened Unreal As Administrator and created a new C++ Code Project (3rd Person) and everything went smoothly. I also tried opening Unreal without doing As Administrator and it worked fine too. Sooooo yea. Hope this helps someone in the future.