Cannot not be compiled. Try rebuilding from source mannually! - Giving errors in Visual Studio

I was installing a third party plugin to fix Android 12 issue for google console as per new policy. I created a new folder as “Plugins” and paste my plugin folder there. And I opened my project, I’ve manually enabled my plugin and restart the editor. The next time when my project opens I got this

error 1

when I clicked yes it tried to rebuild but unsuccessful and gave this error

Error 2

I saw some youtube tutorial so I right click on my project file and clicked “Generate Visual Studio Project Files”
And then I got an sln file and I opened it with visual studio and tried to build my file by ctrl+shift+b as per youtube tutorials I got 2 errors.
![visual studio error|690x376]

Please help me fix these error, I spend my time more than 8 months on this project and I completed my project but this happens.

Perhaps you need to compile the plugin manually. This is a step that is not done automatically by vs. You need to open the plugins folder in the solution explorer and compile it manually. You should be able to build that specific folder separately from the project (it has it’s own build file).

This may fix the problem, but if it was built for another version of the engine besides your 4.27 then you might need to update deprecated code to get it up to your version standards.

Also make sure you have all of the android SDK setup correctly

Could you either pack the plugin folder or send a link to the android fix repository or source? I could then test if it compiles and runs on 4.27 on my end.

is it this by any chance?

Did you put it in the correct directory? It compile fine on my pc.

Here is a packed version of my plugins folder just in case. Perhaps you unpacked the cloned source with the extra directory? (7.9 MB)

Also be sure to delete the folders

  • binaries
  • intermediate
  • derivedDataCache
  • saved
  • .vs
    And the projectName.sln file

The right click your uproject file and choose
“Generate Visual Studio project files”

Then run the .sln file and compile the project from within visual studio.
It should run the editor with your project and the plugin should be ready to load.

The plugin you gave me link of, yes I am using that one. But as I am new to Unreal engine and doing this first time I dont know how to compile plugin manually. I have setup my sdk ndk properly .I am using UE4.27, I have tried deleting all binaries folder from the project but still giving me the same error when building on visual studio.
I even replaced my android12fix plugin with your given plugin zip file but didn’t worked. And now its not even showing plugin name in the error. Rampit is my game name in case if you get confused.


In case you need to check my logs from save folder of my project here it is:

RampIt.log (12.9 KB)
UnrealVersionSelector-2023.05.11-16.14.28.log (32.6 KB)

Could you please tell me how to compile plugins manually as you said, may it will work.

But it seems from your post that it is not having problems with the plugin directly but with the project.

Have you switched engine versions during the development process? (upgrade or downgraded)

If so then deleting the folders I mentioned and rebuilding should also help.

The plugin doesn’t seem to have all the files to do a separate compile, but it does compile with the project so maybe it doesn’t need the extra configuration.

No I haven’t switch Engine version while development. I guess using your plugin file fixed my plugin build issue but having a new error in visual studio. Please guide me if you know how to fix.

As you can see its telling me to add a line in a file. I’ve found that file but as I have no coding experience could you tell me where I should add this line?

And also what about the second error?

As I could remember the second error is most probably because of the unsuccessful build in command prompt. I saw this video and did what he told.
Video Link:

You could try modifying the .Target.cs files in you project adding bPrecompile = true;

For both YourProjectName .Target.cs and YourProjectName Editor.Target.cs

// Fill out your copyright notice in the Description page of Project Settings.

using UnrealBuildTool;
using System.Collections.Generic;

public class YourProjectNameTarget : TargetRules
	public YourProjectNameTarget(TargetInfo Target) : base(Target)
		Type = TargetType.Game;
		DefaultBuildSettings = BuildSettingsVersion.V2;

		ExtraModuleNames.AddRange( new string[] { "YourProjectName" } 

		bPrecompile = true;


Nope, doesn’t worked. Now I cant even generate project file of my project show this error:

so I undo the line.

Edit: You put the bPrecompile = true; in the wrong place

here is an example of a proper target file:

using UnrealBuildTool;
using System.Collections.Generic;

public class NavigateCornerEditorTarget : TargetRules
	public NavigateCornerEditorTarget(TargetInfo Target) : base(Target)
		Type = TargetType.Editor;
		DefaultBuildSettings = BuildSettingsVersion.V2;

		ExtraModuleNames.AddRange( new string[] { "NavigateCorner" } );

        bPrecompile = true;

Ok I did it and I got not error but when I build my project in visual studio I got error:

See if commenting out “AndroidAvertising” from the extra modules helps.

If I try to add it to my build file in the dependencies it causes the build to fail.
Perhaps the problem lies in the uproject file internal settings?

Could you post what is there?

how can I post internal settings I dont know. Tell me how to I will post it.

Just open up the uproject file in notepad. It’s a human readable text file.

Do You mean this one?


Here you go:

RampIt Text.txt (2.1 KB)

My configuration in the uproject is minimal even though the plugin is enabled

	"FileVersion": 3,
	"EngineAssociation": "4.27",
	"Category": "",
	"Description": "",
	"Modules": [
			"Name": "NavigateCorner",
			"Type": "Runtime",
			"LoadingPhase": "Default"

wtf but can It be the problem?

I’m installing android studio and will try a basic project to see it it compiles for Android with the plugin (I usually code for desktop)

Ok, thank you for your efforts. Till then I’ll go through the internet to solve this error. Reply this post If you finds something.