Download

Cannot make it dark

Hello,
I’m just starting out, trying to understand why I cannot make it completely dark in the “first person” blueprint level.
I deleted everything I thought might play a role in lighting: directional light, sky, atmospheric fog and tried to copy the situation one finds in a new, empty level, where it’s actually complete darkness.
Why does the light not disappear completely?
My guess is it’s in the blueprint, however I can’t really check, because I don’t understand those yet.
Please see the attached images for lightsituation and world outliner.
Sorry for ther meganooby question.
77ef12ff4dc8e7d99f64dde73bff8c887c43bc80.jpeg

I’m having the same issue.

When playing on a mobile device, it is as dark as it should be, but playing on PIE, there is always this phantom light that is illuminating everything.

When you delete all lights, I believe it defaults to the unlit viewport. I’m assuming you rebuilt the lighting after removal, and checked for post processing?

I believe the template projects have an environment color enabled in the World Settings of the level. Go to Window > World Settings if you don’t see it next to your details panel already. There is a Lightmass Settings module and in there is an environment color that can be set to black. And of course, lighting needs to be rebuilt in order to see the correct lighting from any settings or new/deleted lights.

its funny that i who hate building lights know that error exactly…

Go to your world settings and set precompute lights on.
Build the light.
If there is no light in it should all be black now.

What you actually is is the rest of the prebuild, its tricky to find that out.

Thanks for your replies!

@SE_JonF
The viewport is lit.

@StephaBon
Environment Color set to black indeed makes everything dark! That’s progress, thanks!
However in a “daylight situation” if you change that color you can nicely control the shadow color. I imagine, that for nighttime or just darker environments one might also need some control over shadow colors. Therefore I wonder if there is some other solution which takes that into account.

@Kanizitas
I can only find “precompute visibility” in world settings, which gives me an error, because of a missing volume that’s needed for that function.
I guess that is not the same option you suggested?

Hi Dobby,

I think this is because of eye adaption. Try to disable or change the parameters in your global post process volume. Eye adaption tries to simulate the effect when walking from a lit space into a dark room. The pupils of the eyes wides to let us receive more light to see in the darkness. But in UE4 this effect needs the right settings in a dark enviroment to appear right.

@doTERRA eye adaption requires dx 11, thus your level appear dark on mobile.

Thanks, MrRabbit,
that indeed seems to be the setting to play with. It can be found (in the global postprocess) as “Auto Exposure”. I just tried around and setting low and high percent to 100 makes the level quite dark.