Cannot join server hosted over VPN emulated LAN

Hello Folks,

I tried testing a build of my game this weekend over Evolve (Hamachi but actually working) with a friend of mine, the session handling code of the project corresponds to that of the Multiplayer Shootout example. We were able to see our games in the lobby without any problem, but the joining didn’t work, and the game just hung up. I use


I managed to replicate this on a new Project (MEGA )

Steps to reproduce:

  1. Download Packaged Project MEGA
  2. Start the game on two different computers that are connected over Evolve/any VPN. They must not be in the same physical network (Otherwise your connection will just use that).
  3. Press Backspace on one of the computers to host a lobby
  4. Press Space on the other computer to search for and join the session
  5. It will say that it found a Lobby and tries to join, but will be stuck in joining forever
  6. If you take the IP of the host that Evolve gives you (eg. on the destined client and type “open” on the console (that means a direct connection over IP from client to host), the connection works without any flaw

After looking at the Log of the client I found the following line:

2017.11.21-20.32.48:560][479]LogOnline: Join session: traveling to

I should add that is the IP adress my computer (the host in this case) has in my local network.

After that it just spams this:

[2017.11.21-20.32.48:625][483]LogWorld: Warning: SetActiveLevelCollection attempted to use an out of date NetDriver: GameNetDriver

So it seems that the Engine doesn’t broadcast the Evolve IP to the clients in the Join Sessions Handle, but the IP that it has in my local network. Which obviously doesn’t direct to me on the client.

I am using Evolve, as in my experience it is the best of the VPN programs I used so far. We never had any problem running any game over Evolve, so I can’t imagine it’s a configuration problem on our side. (And I have seen other questions here indicating the same problem). I’d bet it would be the same with Hamachi, Tunngle or any other VPN program.

cmd-> netstat-rn shows me that the priority of Evolve is higher than that of my physical LAN.

Disabling IPv6 in the Evolve Adapter options doesn’t change anything.

Are there any news on the topic?
It’s a game breaking bug whitout a workaround it seems.