Download

Cannot install Unreal Engine

I tried to install UE via Game Launcher. There is not Donwload Button but only the UE button, which tells me, that UE is not installed. When i try the installer, which i can download via my account, it tells me to close my Game launcher and then gives me the options to repair or delete game launcher. Repair stops with an error.

1 Like

at the top of the launcher in the unreal engine library, click the + symbol and choose the version you want installed :slight_smile:

4 Likes

I am having the same problem when I try to upgrade unrealengine it ask to pick the free or paid lisence. it wants to repair. I uninstalled all my games and unreal launcher then put the unrealengine on but then could not install games. so i removed the launcher. then installed the games but then it would not let me install the launcher. someone really messed this up.

Its really messed up that if we uninstall the launcher that the dozen of games we have installed are all broken then and need reinstalled so far i have had to redownload fortnite and dauntless and a half dozen other games over and over just trying to get unreal engine to update. Then i started to get some crashes when i would start a game or the launchar and was forced to use iobit uninstaller to totaly remove them all again. please rethink this launcher and fix it so the games are loaded seperatly or somethign.

Epic Games Launcher is such a crap! Seriously, who would have though you need to click “Library” to download Unreal Engine from Launcher - not Download button on the first page, not a top right corner with Not-Downloaded link. Spent 30 min figuring out what to do. Crap crap crap

2 Likes

got epic games open but won give me unreal

It says it finished downloading but it’s not doing anything. It’s been like this for a few hours. Included partial screenshot.

I am having the same issue as you @darthhawk, then I stopped it or paused it actually and tried to resume and its stuck on please wait…

when i click the install ‘EPIC GAMES’ says ‘THE PAGE YOUR LOOKING FOR WAS NOT FOUND’

It’s been hours since I am trying to install it, and, when it’s about to finish, it just frozes in 82%
I would like to know if there’s any way to fix this, please. The screenshot above shows that.

i started downloading UE_4.25.3 after some time its stopped downloading and saying some network issues i tried with different visions of UE but all are same results.
i checked my network its working fine and i restarted my computer 3 times still iam getting this issues

Can please some one help me please

I get another problem when i try to download engine (any engine) … I need help

Hello!

I’m having issues installing UE4 as well. I have the Epic Games app, have clicked on “install Engine”, but it keeps telling me I am out of space. It says I have only 22GB free out of the 28 needed which isn’t true, I have 53GB!

I turned my computer on and off, uninstalled Epic Games and reinstalled it, signed in an out, nothing works. Any idea where the problem is?

Thanks for your time :slight_smile:

EDIT: finally solved my issue. Found out a big part of my free space was “purgeable” so I had to create huge files with a terminal until my computer told me my “disk is critically low”, and then deleted all files to purge all the memory.

Make sure its not Library on the side… It needs to be here:

2 Likes

thank you so much

1 Like

yea i know how to do that but my problem is that the + and intall dropdown button are grey and i cant press the bouttons

@Grim_reaper_1357 I got the same issue, tried reinstalling the launcher, launched UE4 Editor, closed it, opened up a few links and then somehow the + button became yellow again! It’s very very very buggy…