Cannot install Unreal Engine

Similar problem. I haven`t got any unreal engine versions installed, when pushing “Install Engine” button at the top right corner nothing happens

Experiencing the same issue as @Altair7610. Just doesn’t want to install.

Has this been fixed I cant download the button is gray and library is empty

same problem

Same problem here :frowning:

Hi Folks,

uninstalling and reinstalling several times does not change anything on EpicInstaller Build 12.1.7-enterprise( installation tried out on 18.08.2021).
What worked for me was a click on the install button for Twinmotion. After a few seconds, the Install Button for the Engine was reactive again and I could proceed.

You might have to delete the original Program Files folder for the concerned UE version, if as in my case you had a working version already installed.

Well, good luck.


That worked for me, TX

for anyone who have the + greyed out problem, mine got fix by clicking download early access button on ue5 tab

hope it helps


Yeahhh! that works for me. UE 5 early acces and it appear. At first time I cannot change version so I clicked again and TACHANN I can install version I need

1 Like

I’ve been having the same issue, and what worked for me was to just leave it for a few hours. :smiley: So odd, but after trying a lot of the recommendations above without any success, I just walked away for a couple hours, and when I came back, it already had 4.27 displayed, ready to install.
Maybe grab a cup of coffee, chat around the water cooler, and it’ll fix itself? :smiley: Could be some server authorization feedback loop going on, and eventually it just works…


Had this issue, deleted an old projects folder, clicked ‘Edit Vault Cache Location’ and cleared that. The Install 4.27.0 popped back up.


Oct '20

Make sure its not Library on the side… It needs to be here:

November 2021 and couldnt figure out where to download the engine either

thank you <3

1 Like

That’s kind a stupid UI, why the default option not called from the same place it is telling “not installed”? :smiley:

This fix works with Epic Games Launcher (deployed by EpicInstaller 13.0.0.).
I wonder why it isn’t fixed yet.

  1. Temporarily disable background applications. You can use the steps in this article to do this.

  2. Make sure you have read/write access to the selected install path.

  3. Navigate to your selected install location.

  4. Right-click the installation folder and click Properties.

  5. Click the Security tab.

  6. Click on your username in the Group or user names box.

  7. Verify that there is a check under Allow beside both Read and Write in the Permissions box.

I am SO happy you posted this response… I have been trying for a couple hours to figure this out.

Finally installing!

I tried to install UE 4.27.2 and it was downloading and then my PC’s internet turned off and it didn’t give me an option to turn it back on so I had to restart my PC, after that an error came when I opened Epic Games Launcher (Download Error) it didn’t give me an option to resume the download instead it told me "Directory must be empty. and I don’t know what that means, does it mean to delete all the files that was installed? Or something else.

Thank you, this worked wonders!

I just ran into this, you should relaunch the epic launcher and use “Run as Administrator”. Or change the install directory to a directory with security settings to allow adding files without admin. i.e. not the Programs Files folder

1 Like

For the + button greyed out problem, close the launcher and then try clicking the “open launcher” button at the download instructions site (Download Unreal Engine - Unreal Engine).