Cannot increase game window size more than screen resolution

I’m having an issue with matinee (or any game window that is) that’s greater than my screen resolution.

I’m currently using 4.11.2 (tried on both the binary version and compiled the editor myself). When attempting to set the game window larger than the screen resolution it caps it.

I have 2 side-by-side monitors, both running at 1680x1050, so the largest window I can get is 3360x1027 (seems to expand it up to the taskbar). This happens when I use my own -ResX/-ResY commands with the editor, AND with the matinee setup in the editor itself - both PIE and in a stand alone process.

Curiously, this was not an issue in 4.10.4. I created a new project in 4.10, setup a matinee to record at 4K, and it produced a great video.

Moved that project to 4.11, tried to render the same matinee, and it rendered a file that shows it’s details as 3840x2160, plays like it’s 16x9, but the in game resolution was 1825x1027 so I ended up with a very tall (stretched height-wise) frame that was actually cut off at the bottom and top. Rendering the same matinee at 1680x1050 worked fine in 4.11 (though as a separate issue it looks like a little worse quality than rendering in 4.10).

Anything anyone could share? I really need to do some high quality video rendering and I’m currently at a loss…

This is the most other information I could find on the subject. It looks like a similar issue, but since no one else is clamoring about this I thought I may be doing something wrong here: EXR output set to 960x540 - Cinematics & Media - Unreal Engine Forums

Hi Cameron Abt,

Are you using -ForceRes with a standalone process? Another thing to check is your camera aspect ratio. I believe the aspect ratio on your camera needs to match the ratio you’re trying to export (this is new in 4.11).


, thanks so much for the response.

Unfortunately your suggestions weren’t the answer. I tried with and without -ForceRes and can confirm it is working to force at least a higher resolution. With a 4K resolution setting in the Render Movie Settings, it will produce a 1400x875 game on my screen without it, but it will produce a much larger size using -ForceRes (though I can’t confirm that the window size it produces is actually 4K, although it looks pretty close).

Locking the camera aspect ratio at 16x9 is weird, because it produces large black bars on either side of the supposedly 16x9 game window. I’m going to attach some videos so it’s more clear. This was just a test project with a quick Matinee created.

link text < 4K ratio constrained

link text < 720p (works fine)

Any other suggestions you have would be greatly appreciated.


One more file, since the limit is 5MB.

link text < 4K ratio unconstrained

Hi Cameron Abt,

I had previously entered a bug for this (UE-29171), but there is currently no fix for it. Unfortunately there is not a known workaround for it at the moment.



Looking for that number, I found this article: [4.11.0] Matinee render 4K movie on 1080p saves only quarter of the frame - Asset Creation - Epic Developer Community Forums

Would you be able to document your steps to render a 4K movie without using a separate process?


Ah yes, if you uncheck the Separate Process box and use all the same other settings, it’ll open a small editor window, but render whatever resolution you put in your render settings. Apologies for not suggesting that, we are working out some kinks in our latest builds with this process, but it should work fine in 4.11