Cannot find any sessions [Online or LAN]


I have been following this tutorial series for ue4 blueprint Blueprint Multiplayer: Find a Match Graph | 11 | v4.11 Tutorial Series | Unreal Engine - YouTube

I have followed the tutorial several times however I still cannot find any sessions via LAN or Internet. I am pretty lost as to how to fix this.

Below are screenshots of the matchmaking

Here is the ini file I copied as instructed on the tutorial.









If anyone has any ideas how to fix this it would be extremely appreciated.

Kind Regards

Hey LittleBigProgramming,

Have you setup your project to work with an online subsystem? Either Steam or OnlineSubsystemNull?

Also, is there another client running that is hosting a game so when you search for a session, it can be found?



I copied the ini file from the tutorial for the DefaultEngine. I have tried using both
DefaultPlatformService=Steam and DefaultPlatformService=Null (I thought this was what was needed for LAN).

I am running the same project from my laptop and hosting a game and joining on my computer and vice versa. They are the exact same version of the project which was how it was shown in the video.

Many Thanks


From 4.13 there is a new place where is should be set to Steam, in the Engine click Edit/Plugins/Online Platform/Online Subsystem Steam. Check this in, and restart the engine, maybe this will fix it. The tutorial was made pre 4.13, that’s why this step is not included in there.

Is this the case with 4.12.5? That is the version of the engine which I am using.

I am not sure. Try to check if this option is already implemented, if it is there, check it in, and try it this way!

Steam subsystem requires additional changes to .ini file. read here

Sorry I didn’t specify I added them changes as part of the tutorial. I have edited my question to contain the .ini file contents.

Do you have DynamicallyLoadedModuleNames.Add("OnlineSubsystemSteam"); in you Build.cs file?

Yeah it’s there already it seems. Must have added it automatically.

Did you check the Steam plugin?

Sorry yes I checked and it is included. I’m starting to think it is a blueprint problem at this point.

Hey LittleBigProgramming,

This is usually what I do to create / join sessions with Blueprint:

If it is failing to join a session, it could be a couple things.

How are you hosting the session? As in, are you hosting and joining the game on the same computer with two windows? Or, are you running the game on two computers?

Thank you for your reply. I have implemented your blueprint instead of the one I was using previously. It now says failed to join session.

I have tried this on several PC’s using LAN/Online and still says the same. It just can’t find sessions.

I have tried both, but currently I am hosting and joining on the same computer with two windows. Could this impact the outcome?

If you are trying to host/join via Steam, yeah, this would prevent you from doing so. Steam doesn’t like to handle two connections with one computer / Steam account.

However, if you are not using Steam, you should be able to run two clients (host/client) on the same machine.