Cannot export the active 3D view - Revit 2020.2 / Datasmith plugin 4.24

I just downloaded and installed Unreal Datasmith plugin in for 4.24. into Revit 2020.2. With a model of 3 walls and a floor, I am getting the below error on export. What am I doing wrong?

Object reference not set to an instance of an object.

at Autodesk.Revit.DB.CustomExporter.Export(View view)
at DatasmithRevitExporter.DatasmithRevitCommand.Execute(ExternalCommandData in_commandData, String& out_commandMessage, ElementSet out_elements)

Can you wetranfer me the revit model? We are going to look at the crash here. Please send it to with your name and description.

File emailed.

Same problem here, datasmith 4.24.1 and Revit 2020.2…have you got any luck to solve the issue?

I noticed is something related to the phases, infact exporting models without them is currently working…
I’m trying with a model with 90 phases (for 4d implementation) and it’s having that problem mentioned before…

Sent model to Epic Staff and they are looking at it. My model was very small with only 3 walls and floor added to the arch template. I used a larger model of an interior and it worked fine. Revit Interior was set to Complete with no overrides.

send me the file as well?

So far we found 2 causes of exporter crash in 4.24.:

  1. Views containing project base point → try turning this off in the views overrides, that might no longer crash?
  2. Exporting from the family editor → for some reason, that use case never came across our mind. Insert the family in a model, then export to Datasmith

Let us know what your findings are!

I also have the same issue…
I can export the template models but once I load a project I get the error mentioned above.

Hi Pierre,
it did not solve my issue, however I’m sending you the model via Wetransfer, please have a look to it, it continues to generate this error, also turning off all overrides.

Thanks we’re looking into it

Ok then, we wait for your idea back!

send me an email at so we can have a look?

I’m having this exact same problem! Need a fix urgently :confused:

Hi all,

If this could help : I have the same problem and I cannot export from revit to datasmith with the same export error message.
The weird thing is that I can export an older file without problem (and only one…) but every other file has the same bug. I tried filters, removing phases, materials… and that doesn’t help. I even tried to create a new file (revit 2020.2) from scratch with an official autodesk template and … same error.

The file that works on export was created with revit 2020 (not 2020.2), so I tried to convert that file to a template for a new project with revit 2020.2 and got the same export error as the other files.

I tried to revert to revit 2020 without the 2020.2 patch, but every time I uninstall it, it installs the new one (2020.2) …

Perhaps the 2020.2 update may cause this problem ?

Revit 2020.2 Is keeping many troubles, maybe they enforced a security control and some internal changes into project files structure…

So far we have identified the issues on our side (the exporter plugin seems to trip over some entity types and fails). Ping me privately at if you have cases where our revit exporter crashes as reported in this forum we will see how we can help out.

I just sent you the file. Thank you for your help.

Can you export Revit 2020.2 using the Datasmith exporter and 4.23? I am concerned because i have two projects that are now in Revit 2020 and I am not encouraged by the things I am seeing using 4.24 with them. I’ll give it a go in 4.24 but getting a bit nervous.

Yes it’s a correct workflow at the moment, export in 4.23 and raise to 4.24 version then if you need.