Download

Cannot disable refraction on parts of the material

Hello,

I want to disable refraction on parts of the material, like I can make parts of the material fully translucent (opacity = 0) or mask them out. With refractions this does not seem to work. opacity = 0 or refraction = 0 has no effect, it’s always on the whole material refracted.

Thank you,

Thilo

Can you possibly post a picture / screenshot of what you’re trying to achieve with this? That might help track down a solution…

Try setting refraction to 1, not 0, for the areas you’d like it disabled.

If you use raytracing for your transparent materials, then the specular input is used for raytraced refraction. So test, if you can disable your refraction via specular input.

Thank you all. I had to set refraction to 1, not to 0 like you do it with opacity, to disable it,