Cannot debug in Visual Studio, neither by attaching or starting from Visual Studio

Hi,

I couldn’t find a way to debug my C++ code in Visual Studio. I’ve searched everywhere but no avail.

I created a project from the template of 3rd person with C++, without any modification.

If I try to start a debug instance from Visual Studio (F5), Visual Studio will crash.

If I run Unreal Editor first and attach Visual Studio. It will tell me: The debugger’s worker process (msvsmon.exe) unexpectedly exited. Debugging will be aborted.

Some detail:

  • I use Unreal Engine 4.15.1 launched from the Epic Game launcher.

  • I use Visual Studio 2015.

  • I tried different config (DebugGame, DebugGameEditor, DevelopmentGame, DevelopmentGameEditor). I have the same problems.

Help me please. I have experience working in UE2, UE3 for commercial titles. They were all C++ work. I’m surprised that in the new era of UE4, it’s so C++ unfriendly. The whole tech seems promoting Blueprint only. UE would never be successful again if it were only following path of engines such Unity. I haven’t started working on the real development. But I read from the forum that common tasks like playing animation in c++ is also a pain in the ■■■. I almost want to give up using Unreal.

Thanks,
Will

I am not sure why you are having an issue.

If you’ve created a C++ project, open the .sln that is created with that project, which will open Visual Studio. By default the Startup Project will be your game project.

Make sure you have the correct development setting, platform, and project selected from the options bar.

I use either Debug Editor or Development Editor with Win64.

You can then run by using the “Local Windows Debugger” button, which will launch the project.

Thanks. I think Visual Studio has to do with it. I installed Visual Studio 2017, everything works fine. What’s weird is that when I use 2015 now it also works fine. I guess by installing 2017, it repairs the system.