"Cannot create new folders in ..."


I cannot create new folders in the c++ code source folder in the ue4 editor. I downloaded the Shooter Game template and when I right click on the source code folder the “new folder” button is grey out. Even if I create new c++ class in a different folder the folder doesnt appear …

thank you for your help,


Apologies, the “New Folder” option for C++ classes was never hooked up, however you should just be able to type in a sub-path when using the “New C++ Class” option, and then the addition of that class will cause your new sub-folder to appear.

The phrasing of your question makes it sound like that might not be working though? If so, has your new class definitely been compiled? (This should happen automatically unless you changed your project settings to require a manual compile and hot-reload).

1 Like

Hey, no problem,

I tried with “New C++ class”. I add my folder in the path field. I validate this, unreal creates all its stuff and compile the new class. After this the folder still does not appear in the the project. I also tried to compile in VS with the config development editor (the folder is existing on the vs side), and my folder is still unexist in UE editor :(.

Okay now its working. My class did not inherit from any unreal class thats why it didn’t show off . Thank you for your time, have a good sunday !

Strange. I just tested this myself and it worked as expected.

What class were you trying to create, and what path were you trying to create it at? I also assume from your screenshot that you’re using the ShooterGame sample project?

Also, could you check for me that you have “Show Folders” enabled under the “View Options” in the Content Browser. Thanks.

4 years later and its still not hooked up?

1 Like

Still not hooked up

1 Like

I had the same issue in UE 4.25.

I fixed this by opening a different Content Browser (CB). Originally I was using CB1, but switching to CB2 fixed the issue.

OS: Windows

For me, it got solved by running the Unreal Engine as Administrator.

(right-click on UE4 icon and then click Run as administrator)

I wish my employer would let me ignore bugs for five years…

1 Like

4.26.0, technology is still not there :slight_smile:

How’d you solved this?For example, the exact steps you did.

i’v been encounter is right now

I really appreciate if you reply me

5.1 and I still have 50 C++ files of all different types in one folder lol

1 Like

This is still broken in 5.1, 7 years after the first post RIP. We still cannot create folders in the UE editor, I have tried running as admin, tried updating my rider link plugin, tried using the public/private folder layouts.

Trying to get C++ files to show reliably in both rider and the UE editor is still very buggy

did you try deleting and regenerating project files? this usually works

What you can do is when adding a new C++ class, define the folder within which to add. You can add a new folder at this step. Afterwards, when you recompile the project, the class will be in the correct folder and the folder will show up in the UE editor.

For anyone still having this issue in 5.X:

Everybody who has said add the path in the “Add C++ Class” Dialogue is correct - this will place the new C++ class within a subfolder. However, it is still not visible in the editor, even after recompiling. This also means you cannot create a Blueprint class from it.

Steps to fix

  1. Add new class with the dialogue, adding the path to the save location
  2. Close the editor and VS Code / Studio
  3. Go to the project folder and delete the .code-workspace or .sln file and the Binaries and Intermediate folder.
  4. Open the .uproject file
  5. It will prompt you to rebuild, select “Yes”
  6. Regenerate VS Code / VS Studio files from Tools → Generate VS Project

Your C++ classes should now be visible in the Content Browser. I have not found a way around this - I have to do it for each new class, but it keeps everything tidy.

I’m also using Perforce - I don’t seem to have this issue on non-VCed projects, so maybe that has something to do with it.



It looks like a lot of hassle, but at least that workflow worked for me. I can see the codes I create inside the subfolders in the main “C++ Classes” folder. So at least there is a way. Thank you for sharing it.

I had a very similar issue with this and my problem was ultimately that when trying to compile from vsc it couldn’t link the .cpp + .h files because the whatever.h ‘didnt exist’ however the actual problem was that the generated includes were wrong and i had to correct it manually. hope that helps someone 'cause it was frustrating esp. since it was working before. lol