Cannot create C++ Projekt 4.7.3

When I try to create a New Project I am getting the following log output:

Failed to generate project files. Log output:
Running C:/Program Files/Epic Games/4.7/Engine/Binaries/DotNET/UnrealBuildTool.exe -projectfiles -project=“C:/Users/marko_000/Documents/Unreal Projects/ÜbungCplusplus2/ÜbungCplusplus2.uproject” -game -rocket -progress
UnrealBuildTool Exception: UnrealBuildTool.IniParsingException: Trying to parse key/value pair that doesn’t belong to any section in C:\Users\marko_000\Documents\Unreal Projects?bungCplusplus2\Config\DefaultEngine.ini, line 1: ???
bei UnrealBuildTool.ConfigCacheIni.ParseIniFile(String Filename)
bei UnrealBuildTool.ConfigCacheIni.Init(UnrealTargetPlatform Platform, String BaseIniName, String ProjectDirectory, String EngineDirectory)
bei UnrealBuildTool.HTML5SDKInfo.EnsureConfigCacheIsReady()
bei UnrealBuildTool.HTML5SDKInfo.EmscriptenSDKPath()
bei UnrealBuildTool.HTML5Platform.HasRequiredManualSDKInternal()
bei UnrealBuildTool.UEBuildPlatform.ManageAndValidateSDK()
bei UnrealBuildTool.UnrealBuildTool.RegisterAllUBTClasses(Boolean bSkipBuildPlatforms)
bei UnrealBuildTool.UnrealBuildTool.Main(String[] Arguments)

Any suggestions how I can solve this problem?


Hi Dizzney,

It looks like you’ve set up to create an HTML5 project, have you followed all the instructions for setup here in the HTML5 documentation? And you’re not seeing similar errors in attempting to make a blueprints project?

Hi Dizzney,

Can you attach to this thread your DefaultEngine.ini files. Or if you like you can send to me via PM on the forums, wittlief is the name there too. Thanks very much!

Hi Wittlief,
sorry, I forgot to add:
Later that day when I got this error I tried to reinstall my Visual Studio-Version (I am currently running Ultimate 2013) and now it works. It’s pretty peculiar but it was obviously a Visual Studio problem. When I am creating any project-type (C++ or Blueprint) the UE4-Editor and Visual Studio are running just fine and I can build the project in Visual Studio as well without any problems.

I didn’t have any errors when making a blueprint project.

So I don’t really know where the error came from.

Thanks for the fast reply!