Cannot create C++ projects in Source version, while the Launcher version is working well

Hi, I build the ue4.18, but cannot create any c++ projects, always show me “failed to open selected source code accessor ‘visual studio’”…But the Launcher version can create c++ project, and work well with vs2017… It seems that the source version cannot recognise the vs2017, how to figure it out? Many thanks.

by source version do you mean you compiled it yourself?

did you edit anything if so?

Thank you for your reply, yes, I followed the documentation and compiled it, I didn’t edit anything, just click the Build. The Building is successful, 0 warning 0 error… Actually I can use it create Blueprint project, but any operations associated with Visual Studio were invalid, like I’d like to open a C++ class from the UE editor, I double clicked it but nothing happend… I changed the source accessor to visual studio 2017, not helpful…

i have no idea what could have cause that then. in my vanilla editor i can’t access C++ too as it is bugged out, but i just use notepad++ manually, or open .sln file with vs2017 when i need.

also try to add C++ to the BP project you have made, maybe it will generate the rest of the stuff successfully and you’ll be able to use C++ there.

Oh, thanks McLabin , hope you don’t mind I call you McLabin. yes you are right, I’ve tried in this way, and I also tried to create a new C++ project by using the launcher version, then open it in my custom version. To some degree, it can work, but cannot open the c++ file from the UE directly, the connection between UE and VS is still broken. I tried compile it in another PC, also the UE4.18, while coming the same problem. Then I changed the version, I compiled UE4.16 with same step, it works… So I guess it might be the UE4.18.3’s problem. If any other guys met the same issue with UE4.18, you may try other version.

i have had VS opening in 4.16 too. i am not sure about 4.17 as i skipped this version straight to 4.18
do you know if it happens in 4.17?

i would like to submit a bug report for that if it’s not only me.

I tried 4.17 just now, no problem.

thank you. i’ve made a bug report and i hope they fix it in 4.19

Yes I hope so! thank you