Can you package HandheldAR template project for iOS on Windows?

There are posts on the answerhub that you can package for iOS on Windows as long as the project in blueprint only. I am trying to package the HandheldAR template blueprint only project for iOS on my windows PC. I have set up the packaging and iOS platform settings properly. I disabled the third party plugins too. Whenever I hit package, it throws an error saying “remote compiling requires server name”. With the same settings, I am able to package the third person template project for iOS without any issues. Are there any additional settings required for the AR project? Is it failing because the ARKit plugin is a third party plugin and requires compilation on Mac? Any help will be appreciated!

After going through different settings and experiments, I have come to a conclusion that you can not package AR project for iOS without using a mac. I had to buy a Mac Mini. I was able to successfully compile and package the project using the Mac Mini as remote server.

By remote server do you mean “remote packaging” the software by using the windows machine as your main editor? Asking because I’m in the process of figuring out how the whole development process works for iOS devices using windows

Yes, I have windows machine as my main editor. I am running a mac mini on local network which has Xcode installed and remote desktop enabled. It is a very simple setup. Do ping me if you need more help. I can walk you through the setup.

i actually got a problem with remote Building maybe you can help.
I’m trying to remote build on a MAC-mini (High Sierra 10.13.5) from Windows 8.1 Pro. The SSH-Connections is working and i’ve installed X-Code 9.2 (also tried 9.4 and 10.2 beta) and trying to get (tried others too) running on my iPad (11.4.1), but i get a LogPlayLevel: ERROR: System.FormatException: Invalid input string format. Error.

Full log: link text

Hope you can help,
best regards,

I remember having this issue in one of the projects. I do not remember what I did to solve it. Try making another empty AR project and see if the compilation works. Make sure you have disabled the substance plugin if you have it.

If you have a non-English locale on your mac mini, then change it to English(I believe you have German locale on your mac mini):

Do the iOS provisioning steps:

This might also help you: 4.17.2 IOS Packaging ERROR - Mobile - Epic Developer Community Forums

Try compiling after each change you make, so that you get to the issue. Do post your results here.


thanks for your fast response, sadly i already tried these things, i get the same error even when my macs and pcs locale is english. I tried to get an empty c++ project running on my iPad, same error.

I also got no substance plugin activated.

One thing is kind of strange though, my licence (.mobileprovision and certificate) are marked as valid and auto selected if i dont check them, but when i try setting it up via iphonepackager.exe the green or yellow check doesnt appear, but i dont really know why.
Any ideas?

X-Code version just says 9.2, it should show somewhere if its a beta version, right? Since i downloaded it from the official apple developer site.
I’m using a mac-mini from 2009 with high sierra, although it normally wouldn’t be possible to have it installed, maybe thats a problem too…

It’s a little bit hard to find an error, since i only get this one errormessage. I could send you the errorlog, but it’s always the exact same error, at the exact same progress point.

thanks anyways!

best regards,

Hi BladeMaster, I’m trying to package an APP for IOS on a Windows PC, and this is my first time. Can you walk me through the setup process (Macbook setup and editor setup)?