Download

Can you inherit lighting values from the landscape?

I’m finding the landscape lighting model to be particularly bad right now. During sun movement my landscape self-shadows long before the objects on it receive a shadow from the landscape:

That object should know that it’s sitting on a landscape and what the general landscape lighting value is and inherit it. This is frustrating because it looks so bad it’s hard to imagine why this hasn’t been thought of already.

I can probably do this in a material but that means every single thing on the landscape will need to sample a pre-baked landscape world normal map, calculate the phong value from the sun angle and then light itself, hopefully matching what the landscape does internally along the way. That’s going to lose me a few milliseconds by the time there’s a lot of objects in the world.

Is there a way to do this without going through all that?

Additional question, this is undesirable as well. The sun is behind the peak and the specular peak from the it is showing THROUGH the landscape. Is there a way for it to know that it’s occluded?

Is this happening on all releases?
Does it happen regardless of the sitting object’s size?

I haven’t tried anything older than 4.22. And yes, it happens regardless of the object.

I recall having this problem ages ago but can’t recall how I solved it. Next time I’m in front of my PC I’ll check.

Is your landscape material settings two sided?

I ended up finding a way around it while I was trying to reduce the shadow ribbing, but it came at the usual cost. I increase the exponent of the shadow bias or something in the directional light, that helped. I also added a zero to the dynamic shadow distance because my landscape is pretty massive. Between the two of them the extra geometry now darkens more or less at the same time as the landscape. It’s still a little bit off but that’s not nearly as bad as it was.

The tradeoff of course is that small object shadows are much reduced. Probably not the worst thing to happen.

I still don’t have an answer to the specular highlight showing for obscured directional lights though. That’d be nice to fix as it’s pretty glaring as well.

Edit: Landscape material isn’t two-sided.

@Antidamage about the highlight… is that material using subsurface? Just wondering if that is participating in the issue.

It is. I guess that’s what’s causing it. How can I emulate a layer of snow with an opaque surface beneath it? Subsurface profile instead?

It might be both subsurface and a residual specular causing it. Check what happens if you just go all the way specular with 0 and if the issue disappears.

A second thought is about the skylight and its influence regarding the issue with subsurface. In this case the main directional light angle would be used to reduce the skylight anyway (if the skylight is guilty).