Can only paint foliage on one of two landscapes.[Solved]

Hi. I am using two landscapes. One smaller where the player is interacting and one big in the background. I added the big landscape after the smaller landscape, and the big one goes under the smaller one. The problem is that I can only paint foliage on the big landscape, the brush isn’t even visible on the smaller one, it just goes right through as if it isn’t there. I could paint on the small landscape before I added the big landscape. I still have some foliage on the small landscape.
Why is this happening? Is it a bug? How can I paint on both landscapes? Thanks!

Did you try selecting your other landscape first with shift+1 (or alternatively by going in to the Mode tab and selecting the Place tab to select the other landscape) and then back with shift+3? <3

Yes I have, but it doesn’t work I’m afraid.

I am trying to paint foliage. I have already painted the landscape with the landscape paint tool :slight_smile:

Have you tried restarting the editor? cause i cannot manage to replicate this

wait are your landscapes imported or in-editor created?

I have tried restarting the editor and it doesn’t work. The small landscape is imported from a heightmap. The big landscape is created in-editor.

You can try to set your foliage actor instances to be shared assets; if it doesn’t work try to reimport the heightmap using the landscape manager. Lemme know if that helps!

The foliage is already shared. I have been working alot on the imported landscape. Is there no other way to fix this without reimporting it? Do I have to redo everything? :frowning:

before you go for that make sure that there is no collision or mesh actor standing in the way when you go with the brush over the landscape. Reimporting should be the last option i guess, especially if you worked hard on it

The imported landscape is pretty big so and I find it unlikely that the whole surface is covered in a invisible mesh.
So is this a bug? It is so wierd that the landscape just stopped responding to the foliage brush. I didn’t change any settings.

how many textures samples are you using for that landscape?

In the landscape material? I am using two different instances of the same material on my landscapes. I am using 3 layers with a total of 18 textures in my material.

I followed this guide when i made the landscape material:

I figured out a workaround that isn’t great but it works. I copied a layer in my landscape material and used Landscape Grass Type on it. So if i want to paint a foliage on my landscape I can paint the new material layer with the foliage on it instead. I am still unable to use the foliage paint tool and I would rather use the foliage paint tool.

I had this problem and it was because of the collision preset the landscape was set to.

It would only allow me to paint on my background landscape so my solution was to change the background landscape collision preset to ‘no collision’ and the landscape I want to paint the foliage on to 'block all;

Hope this helps.


1 Like

That worked perfectly!