Can no longer compile project (Failed to produce item:...)

So I have a project that is being shared by 3 other programmers through github. For reasons mysterious to the universe, one of those programmers is using his mac and adding code through xcode instead of VS. I pulled his most recent updates today and went to recompile the project and now I get this.

Error 4 error : Failed to produce item: C:\Users\Documents\Unreal Projects\GalaxyHeist\Binaries\Win64\UE4Editor-GalaxyHeist.dll

I’m assuming this has something to do with him building and coding in Xcode and me using VS? I never have this problem before and wasn’t able to find a fix that worked for me.

Can anyone offer some advice? Thanks!

I’ve had this issue with Perforce once or twice - my /Binaries and /Build folders were not writable, and as such the editor could not create a new DLL there. Check if you have any write restrictions on your folders.

When I check the properties of my folders it is set to read-only but when I uncheck that box and apply it, then re-compile, it just goes right back to making it read only and getting the exact same error.

Any other ideas?

Are you compiling through the editor or via VS? If it’s via the editor, try closing it and using VS. If that doesn’t work, I’m stumped :frowning:

I can’t even open the editor because of this so my entire project has come to a grinding halt…