Camera Transform Breaks after Re-Attaching Specific # Of Times.

I don’t really know how this is even possible but… if I attach the SpringArm of my PlayerController to a different object EXACTLY fifteen times, the camera seems to move further away, but in actual fact the Debug information shows that it’s in EXACTLY the same relative location. When I attach around 20-35 times, the viewport goes completely black.

I’m using a Custom PlayerController that has it’s own CameraSpringArm and Camera, and it ‘Attaches’ those to different actors that are Spawned in the Scene. The PlayerCameraManager has been overridden to use the Controllers’ Camera instead of one on a pawn for example.

I’ve been debugging it for a while, and the Relative Location is always the same, the offset is the same, the target arm length is the same, the scale of the object even seems to be the same… so why is it now attaching further away!? I can’t understand or make sense of this at all, so here’s the Video (Unlisted):

The list on the right of the scene populates with the Spawned Satellites, and I can click them to jump between them. Whenever I hit 'Launch', it spawns a new one and attaches the Controllers' Spring Arm to it.

is there some problem with attaching a Camera to different objects like this?

Have you tried pausing the scene and looking at your player hierarchy when things break? Maybe you’ll notice something fishy like things aren’t attached as you intended. Also another spitball, could the behavior have anything to do with the location of the satellite? Does it happen if you attach/detach from the same satellite 15 times?

Yeah it does, I printed debug info to the screen about what it was attached to (actor and component), the relative locations, the target arm length etc, even camera FOV just in case but it’s none of those things.

What I don’t understand is why it goes black at the very end, as if it can’t get a view target at all. I suspect it might be a conflict in the Camera Manager somewhere perhaps.

I’ve added more detail here:

Update, I’ve added more detail the forum post as well.

I’ve discovered that the Camera has an invalid WS Locaton when the screen goes black, but it still doesn’t explain why it starts moving further away from the Satellite, if that’s even what’s happening!

Fixed by setting AbsoluteScale on the Camera Component. It seems that not having a scale of 1.0 on the camera can in fact cause it to break like this.

Shouldn’t Camera’s always have Absolute Scale anyway?