Camera switch

The question is how to switch the camera from the player to the one created in the blueprint? After starting the game, the camera with the “w a s d” control is displayed. I created a camera in blueprint and want to use it in the game.

You could set up a key to use the Set Active node.

It already has the auto active key, but it does not work

If you want a transition instead of an instant switch use View Target with Blend.

So you’re not switching cameras in the game, you just want to use another one from the start?


Did you turn off auto-activate on the original one?

So where is the original?

Are you using a third person template?

What exactly is TBS_CAM? Is it just a plain actor? Or something else?

I think the enabling/auto activate with cameras is effective only when there are multiple cameras on the same actor.

1 Like

Blueprint class “Actor”

That is, you need to disable the activation of the main character’s camera? How to do it?


Putting this in your Actor’s Blueprint should do the trick:

But, beware: the default pawn (the default camera controlled with “w a s d”) will still be there. Changing the Default Pawn Class in your GameMode to “Pawn” will make it no longer there.

Thank you so much!

You’re welcome! :smiley:

What am I doing wrong, I want to zoom in and out of the camera?

You need to connect the “Get Length” variable node to the "0"s on the addition nodes.