Camera near clipping plane

Is it possible to change the value for near clipping plane on created cameras? I have huge troubles with camera clipping through geometry, especially when trying to set up a first person matinee with a gun and what-not.


Can somebody adress any performance or other issues we should be aware of when modifying the clipping plane?

I personally met a problem with the shadows :

Regarding performances I didn’t see any particular change.

The main problem you will see with pushing the near plane closer to zero is that you will lose a lot of depth precision which can lead to z-fighting.

Currently this is not possible. I went ahead and threw this into our database for consideration.


Thanks a lot for your answer! :).
Follow up question: How would one solve this issue for now then without this setting? How do other FPS-games in UE4 solve this? I noticed that the clipping issue disappears if I scale the arms and gun up a lot, is that the solution? Or is there a code-based better solution?

Thanks again!

Hi Markus, in the engine INI:


^^ Set that config value to whatever you’d like the near clip plane to be.

I’m bumping this because I’m trying to change this value and I don’t see any change currently.

I have tried (inside the DefaultEngine.ini of my project) :



While the smooth framerate option works inside the editor, the NearClip option seems to not have any effect at all. I have tried very small and very big value but the clipping remain the same.

I don’t know myself. I’ve reassigned this thread to one of our awesome programmers who may be able to help you. :slight_smile:

NearClipPlane was not a regular class property, so UnrealEd.EditorEngine did not inherit it, which is why your INI change had no effect. I have fixed this in CL# 1902831, and I have also exposed this setting in the Settings UI under Project Settings → Engine → General Settings → Settings where it will remain until we refactor all Engine settings and find a better place for it.

The way it’s set up right now (the value is being cached in a global variable), you won’t be able yet to tweak this setting on the fly, but will have to restart the Editor for changes to take effect (or at least recreate the view ports).

These changes did not make it into the upcoming Beta 5, but they will be available in Beta 6. In the meantime stick with the Engine.Engine INI setting as suggested above. Thanks!

this worked for me:


In the main viewport of the Editor I don’t see any change, even if I change the BaseEngine.ini setting. :frowning:

The problem was solved by itself. I really don’t know why. Today it’s working whila I didn’t change anything. Could it be a ini file that wasn’t updating ? Since I don’t know where the runtime ini file are generated it’s hard to guess…

I would REALLY like to have a near clipping per Camera, too! Please consider making this setting available in the properties of the camera.

Hi Mowfax,

This is an archived post. If you are experiencing a similar issue please feel free to create a new question on AnswerHub or post on the forums.

Thank you, TJ