Download

Camera from Maya into Sequencer

Hi all.

I have brought in an animated camera from Maya into UE4.

I wanted to use Sequencer. Purely because with sequencer, you can also output elements like AO & alpha.

I couldn’t figure out how to get the a pre animated camera to run in sequencer so am having to use matinee.

Can anyone help me with this?

Thanks

What I do is, import the camera fbx to Matinee, and then just simply convert the Matinee to Sequencer.

Thanks. That worked… somewhat.

When I tried to export the frames unreal wasn’t rendering the correct camera. I remembered for matinee, we have to create a blueprint to tell unreal what camera to render. I did this (adapting the blueprint for sequencer) and when trying to render again I had the export preview window in the top left of the screen. It shows the correct camera and I can see that it’s running through the animation.

However, what it exports is a flat image (just one colour). It’s also exporting at a resolution much lower to the one I set up (about 1250x675) whereas I selected 3840x2160.

Anyone know what’s going on?

Thanks

Seem to have fixed it.

In the editor I was in my animation camera. Ejecting from the camera (into perspective) seems to have fixed the issue.

However… I have another issue.

I’ve noticed that the exported png’s are quite low quality. Looking at the image info, I can see that it’s using ZIP compression… I don’t want this. I want no compression.

When selecting the use custom passes option in sequencer export box, there is no info about format choice or compression settings.

Anyone know where I can set these?

Thanks

Well the non compressed files can be written in .bmp format, or if you want HDR frames with custom passes it writes in .exr format ( note that for me a 2560x1440 frame in .exr is around 30mb each :slight_smile: )

Ok, to sum things up.

The only real reason I wanted to use sequencer (for now) was to render separate passes at the same time. Matinee can’t do this. Well, that’s what I thought but whaaaaaaa, it can. I have no idea why I haven’t seen it before in the matinee options.

Ok, I want/need to export 3 passes:

Final
AO
World Normal (so I can make an alpha for the sky).

I need these passes to be done the same time because I’m using animated trees which, if doing it at different times, won’t be in sync.

A couple of days ago I exported the animation with jpg format… It looked good.

Today I’ve been working with sequencer and have noticed that the quality (when using separate passes) is very different to the jpg. As if Unreal is using compression on it. It’s doing the same low quality on all passes.

I’m exporting another test now (not using custom passes) in png format.

The quality is fine, just like the jpgs.

So, it seems to be custom passes feature that is causing me this hassle.

I’ve just tried rendering as a separate process with custom passes and it still looks reduced quality.

I’m attaching a link to some renders. You’ll see what I’m talking about with the difference in quality for the custom pass one. Particularly on the site grass. In a sequence, the pixels jump all over the place. I haven’t changed the resolution because I want people to see them as they came out.


So, my question is this.

Why is this happening? What can I do to get the same quality as when not using custom pass mode?

By default the passes are brought out as png’s.

Do you know where this can be changed? I’d rather work in png’s (or tiffs) over bmp’s but I need to have control of the quality settings for separate passes.

I tried exr’s and they were abt 60mb. My boss wouldn’t be ok with that. There are 7000 frames.

I saw the pictures and that is weird indeed, my stupid question is, do you by any chance have some grain in post processing volume? Also it’s probably best to disable temporal anti aliasing while rendering since it can look like a mess in some cases. The bmp option should be in the dropdown where you can choose from avi, jpg and png (sequencer). Also I recommend rendering a depth pass instead of world normal (if you are not using a BP_Sky_Sphere), the sky will be the only thing that has a pure black value (0,0,0). Another thing you could do (this might be too much work tho), if you actually have space for the .exr’s, you could render your sequence as .exr and then just re-render them in your editing software as uncompressed .png and then you can delete the original .exr’s.

Hi.

No, not using any kind of grain. I never use temporal aa nowadays because of ghosting in animations. I use FXAA, render final animations at double 1080 and half the rendered frames in aftereffects. This comes out really well.

EXR’s aren’t an option. My boss moans because of the double 1080 renders (abt 17mb).

For this job, I’m not using bp_sky_sphere. World normal works great because my sky is the only thing that comes out black.

It looks like I’m going to have to render these passes at different times. I can’t hand over a lower quality result. So, I’m just going to turn off the animation of the trees. It’s annoying but that’ll solve the problem I think.