Download

Calling All Linux Users...

Kaboom Arena needs you to test the Linux build. I haven’t packaged it (other then creating a tar.gz file and added some startup scripts) … I would like to get it tested on different Linux machines and get any feedback I can. The game runs on my test rigs … but I would like some extra testing to be performed … as well as some feedback on any issues encountered and what rigs you tried it on.

Please go here for the latest downloads.

Thank you for time and I look forward to hearing back from you all.

All see if it runs on my pc.
Gtx 550ti
8gb mem
Amd quadcore 3.6ghz.
ubuntu, the latest version.

The game works great on my computer! I tested all the resolutions and graphics settings i could. I never played online though… My internet is way to slow. But it works great!
Hope that helps! Also, It ran around 50-60 fps on medium on my pc. Is that good or bad?

EDIT: I tried it on LAN. And it worked about the same. :slight_smile: (I had 5 players. We had quite a fun little LAN party. It’s quite a fun game.)

Awesome news man … thank you very much for testing. 50 to 60 FPS on a medium PC is what I was expecting. I am glad you had fun with the game, we are now working on the next set of features.

Thank you again for testing, it is greatly appreciated. 8-}

you’re welcome! :slight_smile:

Hi there,

I tried too but the fullscreen doesn’t seem to work correct. Only if I change into native resolution. See here:

Screenshot - 020615 - 03:49:08.jpg

Can you try using the Setup button and change the settings there?

What OS are you running?

Alt-tab out of the program. Then open it again.
This problem happens to me all the time. Hope it fixes you’re problem.

Okay thanks for the feedback … I am planning on changing the whole graphics setup system for the next release … I will do some more thorough testing for this scenario and make sure I nail it.

Thanks @94 and @Yaakuro for testing and providing me the feedback.

We will get it working seamlessly on Linux … you guys have my commitment. 8-}

Are you using 4.7 branch? How about using 4.8? If I change the settings, and select native resolution, it is fullscreen. Somehow in a lower resolution it doesn’t scale correct.

My system:
Ubuntu 14.04.02 LTS, 16Gb RAM, Intel 4600/Nivida 750Ti 2GB

I am using 4.7.6 … packaged for Linux on Windows. I will move to 4.8 when it is released and I have a new system that I am busy implementing to handle the graphic settings. So the next release should address this.

Thanks again for the testing … much appreciated. 8-}

I think I like to know if this is on the UE4 Linux side or the Game Program. If it is the Linux part of the UE4 engine we have to fix that :smiley:

Basically I am using this module - Persistent Graphics Menu - from the Marketplace. Basically I have some default settings sitting in a saved file called Graphics.sav. The system reads this save file on the loading screen (i.e. the logo splash screens) and then sets the game to those settings using the methods provided by that module.

When you change the settings and click Save … it sets the save file to the new settings and then runs the commands from the module to set the various settings for the graphics sub-system.

So that is all I do from my side … no other trickery is involved. I hope that helps a little.

It seems to happen for all my linux games. I just Alt-tab out of it, then open it again and… VOILA! It works for some reason!
(It really seems to be a linux problem. But still, you engine guys should check it out anyway.)

That’s great to hear! It’s all ready running pretty well, so it should run great when you guys are done! :slight_smile:

Right … time for all Linux users again please …

… this version is based off UE 4.8 and hopefully a lot of the issues should be resolved.

Please go here for the latest downloads.

Keen to hear your experiences and also to see if we addressed some of the concerns.

Thanks

It worked great! :slight_smile:
There was less lag when starting a match! Keep up the good work! :slight_smile:

@94: Awesome … thanks for testing and the feedback. 8-}

You are welcome! :slight_smile:

Works great on Mint 17.2 with i7 4710HQ and GTX 860m