C++ First Person project fails to create with compile error

I’ve tried a couple of other posted solutions, such as reinstalling VS, copy the missing file to a missing location, etc.
Additionally, last time I tried to figure out a back end issue on my own, I ended up with a new computer.

Running C:/Program Files (x86)/Epic Games/4.15/Engine/Binaries/DotNET/UnrealBuildTool.exe WoF Development Win64 -project="C:/Users/thech/OneDrive/Documents/Unreal Projects/WoF/WoF.uproject" -editorrecompile -progress -NoHotReloadFromIDE
Creating makefile for WoF (no existing makefile)
Performing full C++ include scan (no include cache file)
@progress push 5%
Parsing headers for WoFEditor
  Running UnrealHeaderTool "C:\Users\thech\OneDrive\Documents\Unreal Projects\WoF\WoF.uproject" "C:\Users\thech\OneDrive\Documents\Unreal Projects\WoF\Intermediate\Build\Win64\WoFEditor\Development\WoFEditor.uhtmanifest" -LogCmds="loginit warning, logexit warning, logdatabase error" -Unattended -WarningsAsErrors -installed
Reflection code generated for WoFEditor in 2.7010398 seconds
@progress pop
Performing 11 actions (4 in parallel)
[3/11] Resource PCLaunch.rc
[2/11] Resource ModuleVersionResource.rc.inl
[10/11] Link UE4Editor-WoF.dll
[11/11] Link UE4Editor-WoF.lib
LINK : fatal error LNK1181: cannot open input file 'ws2_32.lib'
   Creating library C:\Users\thech\OneDrive\Documents\Unreal Projects\WoF\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-WoF.lib and object C:\Users\thech\OneDrive\Documents\Unreal Projects\WoF\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-WoF.exp
ERROR: UBT ERROR: Failed to produce item: C:\Users\thech\OneDrive\Documents\Unreal Projects\WoF\Binaries\Win64\UE4Editor-WoF.dll
Total build time: 35.72 seconds (Local executor: 0.00 seconds)