Download

Burned out already

Really enjoyed unreal. But, sadly the number of problems I found just overwhelmed me i believe.

What finally did it was the landscape and the cloth physics.
It was a hobby. Just having fun and stuff. But when I finally realized since I was working on mobile and the stats didn’t mean it would instantly look fine in those shaders i swapped shaders.
To find that my landscape would NOT load, and that the duster I spent hours upon hours getting to move right wouldnt actually work with cloth physics asset…

then spent weeks and weeks optimizing and redoing the textures, materials etc on the landscape never having them change…
it was too much.
I havent worked on my game in months now because of that.

I know exactly how you feel @Cultusfit. You spend hours on your project only to find that the fruit of your efforts is not what you expected. Better yet, you have to start over again and again. Of course eventually you will get it right…I think. I too am burned out. I personally spent every minute of free time that I had on my unreal projects and they didn’t quite pan out. Albeit you learn quite a lot in the process, so maybe it wasn’t a complete waste of time. It really does make you think twice about the one man development team. I know it’s been done; but you simply won’t have a life if you go in that direction.

You know what it is I think…what really burns you out is the fact it is a hobby. A hobby is something you do when you have time to do it. It’s part time work, and when you spend that precious free time on projects that don’t pan out, it just drains you. If it was a full time effort, you can spend the bulk of your week improving your project and then actually have free time to go do some thing fun.

To some effect, at least in my case, if you are a creative person and simply have a desire to create some form of artwork, maybe your efforts are better focused on something that will produce results with less effort. Like modeling or sculpting for instance. If you can do either, one hour of time in a modeling or sculpting application can yield some encouraging results without having to work through a game engine.

That’s what I’m doing now. Instead of fumbling around in Unreal, I launch Zbrush and just have fun with a new sculpt.

Mobile devices just can’t handle as much, that’s something you have to keep in mind when developing for them (don’t go too far down a path to find out it isn’t supported on mobile)

@junfanbl I do enjoy the ART of the process. I think that is why it has worked so well on being a hobby. Asset creation has been fun. And Drawing up the character, setting his animations. Building the physics. Etc. I love it.
But some things that seem like they should be so simple just fail.

@darthviper107 I think only thing that got me on the mobile was I really expected the engine to at least give warnings once I set everything to my target platform that it might not be supported. Reading the documents, It just didn’t dawn on me that the clothing assets weren’t still considered the original type of mesh thus, not being supported. I Spent quite bit of time watching tutorials and fine tuning the physics to get the duster to move JUST right. Only to learn that it wouldn’t work at all on mobile.

Right now it’s all in the mobile shader for the landscape. I Dont want to go too far without knowing that it will work. I want to make at least one level to test things out. Make sure things are working/rendering properly.
I have at least narrowed it down to where the problem is.

I took a single texture 64x64 (WELL under the size constraints of mobile). Created a level with nothing but a skylight and a cube (so I know the lighting is working and everything seeing the cube).
When I added the texture straight to it as a material it renders just fine.
When I collapse the material node into use material attributes and add in the make material attributes node it still works.

The moment I add in the “layer blend” node it stops rendering.

Far as I can tell in the documentation says layers are acceptable. I have read that the limit on layers has been removed (my final material is under that number any way but, my test material of ONE is clearly under that)

So, I presume for mobile it has to be set up differently than it does for the full shaders or, there is something else going on. And I just can’t even figure out where to look. Using the answer hub and forums, no one ever gives me a valid response.
I have toggled every setting for performance I am aware of. I just dont know…

@Cultusfit

Starting top-down or macro-level with a game concept or theme, is a safer way to get hooked on game dev.
That is unless the character is the gameplay obviously. Otherwise its very easy to get lost or lose your way.
There’s just so many hallways in the maze of learning game design / 3d modelling / coding / game engines…
Its far too easy to get stuck on textures, materials, mobile features, and never find your way out of the maze… :stuck_out_tongue:

i have done a lot already
Did my character, weapons, clothing, several world items like buildings (also got the random building thing from store and like it a lot), gates, tombstones etc.
Materials were acceptable and all look about how I want them in mobile renderer.

Weapon selection works, upgrading them, ammo count, reloading. Leveling character. U.I. (not the prettiest but there and it works how I want, swapping images is much easier.

All that litteraly took less time than I have spent trying to render the landscape material alone… And just how I can’t find anyone anywhere that can tell me why it won’t work drives me crazy.

https://youtube.com/watch?v=EDbLpI4M2IU

(Fixed few things since that video. Took me awhile to figure out why the duster was sticking like that, cloth part considered itself part of noncloth parts so when chest and stuff moved pulled it through.)

Gates work when you walk I to them. Weapons fire, deal damage. If zombies see you the shamble arms out after you when they deal damage if hit you.
I removed static camera also. Sits behind you now.

There is town too, I don’t have anything recent on it. The ground won’t render in a mobile shader at all. And I had originally put in instance mesh. But it has large gates, buildings and fountain. When walk out ask if you want to go to world map.

Whole thing bottle necked on the landscape. Without knowing what is wrong didn’t want to create a bunch more levels/area and them all be worthless. My town area is oversized I’m 99.9% sure. So wanted to start being able to test on my mobile.
And that lead to the discovery that the layer blend node does not work apparently…

The forums are pretty deserted compared to what they were dude. You may have better luck pm’ing one of the landscape guys or calling them to the thread etc. Hint look at some marketplace threads to get an idea of who to ask. After all, all they can say is no! But make sure you’ve done everything possible to describe the problem clearly with images. Unreal is so unwieldy sometimes, its often better to just start out by hunting down something that’s close to what you need, then mod that. The second or third time out, you can go and create it all from zero.

@Cultusfit, check out this thread for more resources like some UE4 Discord channels and Slack: Discord chat for UE4 devs - Unreal Engine Forums
I actually prefer using Discord myself, there are usually plenty of people willing to help and in real time too!.

Also have their is a UE4 thread on Polycount.com. Have you tried that?

Nope. And I do appreciate it. I do have a few people working on things that we help each other out on my discord. Yet everyone seems stumped on this.
Best I can figure there is some setting somewhere buried that got toggled or I dont know to toggle in the first place that they dont think of because it would be common knowledge.

stats.png

@franktech
this is a new discovery since moving the project to 4.20
I’m wondering if i just actually dont have the shaders for the settings i’m trying to use…
oh i will be upset.
I’ll try to get everything all together in another post describing my problem and steps i’ve tried. Dig out all the screen shots so I can show verification of texture size and everything. That way not only can they see the settings, they can skip wasting their time with basic trouble shooting.