BuiltData Error


My team is experiencing this every time we open our project. Everything works fine in the MainMenu Level, if we just ignore this. But its just annoying that we get to see this every time we open the project.

Anyone know how to fix this? We have no idea where to resolve this issue.


Make a copy of your project and remove Intermediate and Saved folders. Did it help?

Nope, that didnt work :frowning:

Half expected, really :(. Could you confirm this is a project converted from a previous version of the editor?

Also, is the Main_Menu asset still present in the project?

Can confirm that we first worked on 4.16 and transitioned the project to 4.17 as soon as it came out. However, when we transitioned, we didn’t get any project errors. This builtdata error has only shown up within the past 2 weeks :frowning:

and yep, the MainMenu level is present in our project and everything in it works fine

I’ll admit I’ve yet to hear about hitting a button and fixing these issues automagically. But here’s what worked for me in the past albeit it was in earlier engine versions:

1: Not keeping the project files on more than one drive. Since this is rather uncommon, I assume you have it all in one place.

2: Simply renaming the asset first and then reloading from disk. In the content browser: Right click on the asset → Asset Actions → Reload

3: Manually removing the asset from the folder and adding it back - this has worked for me more than once when transitioning between versions.

4: A more aggressive version of the above:

  • make a copy of the asset outside of the folder
  • rename it
  • copy it back to the location of the old asset within the project folder
  • select both of them in the Content Browser
  • right click on any of them → Asset Actions → Replace References
  • in the list select only the renamed asset → Consolidate
  • save and close the editor
  • open again, do not restore
  • deleted the old asset with the original name
  • cross you fingers

5: This is time consuming: manually exploring Reference Viewer and scouting for oddities. Perhaps the assets is referencing one of the more underdog classes like the CheatManager that you once tried to use in your custom debugger but did not like it and completed forgot about it… Or you had an object generating structs which were being fed via exposed variable to an ActorSpawn node. With blueprinted structs being as unstable as they are, their dirty flags are my own personal nightmare. These are just examples.

6: And lastly (bar recreating the asset from scratch, that is), manually removing all references and redoing them again. This is by far the most mind numbing thing to pull off but since it’s a level…

Good luck.