Building to iOS on PC

I could build to iOS on PC (create sample project or download scifiHallWay) using 4.7.2
I have another project that upgrade from 4.6.1, I got error when building to iOS

InternalUtils.SafeFileExists: SafeFileExists D:\Program Files\Epic Games\4.7\Engine\Source\Programs\IOS\MobileDeviceInterface\MobileDeviceInterface.csproj=False
BuildCommand.Execute: ERROR: BUILD FAILED
Program.Main: ERROR: AutomationTool terminated with exception:
Program.Main: ERROR: Exception in AutomationTool: Unabled to build Project D:/Program Files/Epic Games/4.7\Engine\Source\Programs\IOS\MobileDeviceInterface\MobileDeviceInterface.csproj. Project file not found.

Is there any configuration when upgrade from 4.6.1?
PS: I use same profile to build
[[link text][1]][1]

33188-projectlauncher.log (18.2 KB)

Hi Batigol,

At first glance this looks like it might be a pathing problem. Can you check that the paths to your project are correct?


Could you explain more detail?
I could open project successful. Where to fix the path?

Trying to build to IOS from 4.8 and getting the exact same error

LogPlayLevel: Program.Main: ERROR: Unabled to build Project C:/Program Files/Epic Games/4.8\Engine\Source\Programs\IOS\MobileDeviceInterface\MobileDeviceInterface.csproj. Project file not found.

I have this exact same error in 4.8.3. For me it occurs when I enable [this engine plugin][1]. Without the plugin enabled, the game builds and launches without any issue. I looked through the source code included with the plugin and there’s no reference to this path name, so I don’t think it’s a plugin error. I don’t know if this is the case with you - but I would hesitate to blame it on anything you’ve actually done. I think that the build tool is at fault.

[Plugin] Http/s REST, blueprintable JSON and Parse REST API manager at once (VaRest) - C++ - Epic Developer Community Forums

Hello GCRev,

If you’re having trouble with plugins and they’re causing trouble with your project when opening, launching or even packaging - - please contact the creator of the plugin directly as we do not support plugins internally.

Thank you and have a nice day!

Thank you for your response. I have notified the creator the plugin, but I don’t think the plugin is actually the problem as the author claims the plugin is compatible with iOS.

The problem isn’t specifically plugins, it just happened to occur to me first when enabling a 3rd party plugin. I can enable the default unreal plugins, like HTML5 Networking, and I get no build errors.

I think the problem is more abstract than that - as far as I can tell, any c++ code that the engine depends on without being built beforehand will drop the build tool. This is unsurprising because there is indeed that warning when creating a new project that c++ deployment to iOS from windows is not supported.

In the interest of testing this problem out I created a blueprint-only project, and launched it successfully to my iOS device. However, when I added a test c++ class to my project to convert the project over to a c++ based project, I get the same error: LogPlayLevel: Program.Main: ERROR: Unable to build Project Games/4.8\Engine\Source\Programs\IOS\MobileDeviceInterface\MobileDeviceInterface.csproj. Project file not found.

Just to reiterate, that file path doesn’t exist. I don’t have a “Programs” folder in my “Engine\Source” folder by default. So whether or not the plugin is supported seems to be irrelevant. This seems to be mostly a build tool related issue.

I was reading around about this and it seems like I might have to use the “RemoteBuildTool” on a mac to properly build the engine. I thought I read somewhere that a mac is ultimately required to deploy an unreal project anyway.

You are using a GitHub release? That csproj file does exist in our source and is used to build a wrapper assembly for deploying files to an iOS device from PC. It’s used by iPhonePackager which is always built as part of an iOS game build on PC, so if that file is missing, then yes, your build will fail. I suspect it is just not being included in the GitHub release and it is definitely not part of the binary release.


We just checked and that file is in the 4.7 and 4.8 branch of GitHub. Are you sure you did a full sync?


Alright so this works, there were no build errors and after 9 years in development, the remote tool finally finished and I had a working app. I just wish there was a faster way, but I’ll live with it if it means I can do a cross-platform deployment.

If this file cannot be found, it’s because you are using the binary version of the engine and not the source. I guess the binaries do not include this file by default but the source does. Follow [this tutorial][1] in order to download and run the source. However, this ultimately means that you’ll have to own a mac or know someone who will let you use their mac to do a remote build. The build tool in the binary version, for whatever reason, can build a blueprint-only project to iOS without requiring you to set up remote connection in the build settings, but the source version does require it.

Unreal build tool is easy to use, but again, a mac machine is required at some point.

Unreal also has this DeltaCopy/RSync feature built into it, but I was unable to get that to work and it’s really difficult to find any troubleshooting info on it.

Downloading Unreal Engine Source Code | Unreal Engine 5.1 Documentation