Building lighting

Whenever I try to build light, my light building process stay stuck at 0%…this happens when I upgrade my project to 4.15, so I think it a bug.

Hey URJASVI,

Try taking a look at our Swarm Agent Troubleshooting Guide to see if that provides you with any ways to resolve the issue for yourself.

Let me know once you have tried the suggested solutions and if you still need assistance.

Cheers,

Andrew Hurley

Tried everything that has mention in that guide but nothing changed and I am using OS X so, I can’t run .exe file. and I also tried clearing memory and cleaning trash but move off from 0%. and now ue 4.14 project is not building light too.

Well, that doesn’t sound good. Are you using the binary version of the engine (from the launcher), or is this a source build from GitHub? Be sure the Swarm Agent is not behind any type of firewall as well.

Thanks,

Andrew H

I am not using source build from GitHub, I am using the binary version of the engine.I tried it from this solution → https://answers.unrealengine.com/questions/25289/building-lighting-in-os-x-editor-stays-at-0-indefi.html <-, and swarm agent was not behind any type of firewall but still it is not moving from 0%.

Ohh THANKS!!! it worked!!!.i did everything that the linked said but it did not work, so on another day I tried opening my project and then a pop-up dialogue asked me to allow or deny connection from the firewall so, clicked on allowed and then I tried to build lighting and then it worked and reached 100%.