Building lighting stuck at 0%


I just created a new project, an empty project. I placed directional light and sky light. I created a standart 2x2 landscape.I pressed build and it got stuck at: Building lighting 0%. I tried it again a couple times but it didn’t work. I restarted my pc and deleted the project, I did the exact same things and it got stuck again.

Please help me.

Greetings Robin

1 Like

Did your editor freeze, crash, or was it just taking a while for progress to be made?

It didn’t freeze or crash. It stayed on 0% for a long time and after that it said: Build lighting failed.

1 Like

Close the editor and delete (or rename) the folder “Saved” from your project.

For example:
“C:\Users\[user_name]\Documents\Unreal Projects\[project_name]\Saved”

Then open it back up and rebuild your lighting.

1 Like

I am having this problem since about 4.15 I think. I was able to build no problem before that but now it does 0% then fails. I just deleted all assets from my scene except the player, a directional light and a ground static mesh and it still fails. Every map I have in the project I am working on. I have opened other projects and it builds. I have tried firewall on firewall off…deleting sworm cache …deleting saved and intermediate folders… all I get is:

LogStaticLightingSystem:Warning: Failed to build lighting!!! Lighting build failed.
Lights with unbuilt interactions: 0
Primitives with unbuilt interactions: 0

Not sure what to do. I have like a years worth of work and I can’t build the lights… :frowning:

I just wanted to post a reply stating this workaround fixed the issue for me.

I simply renamed the “saved” folder to “saved_1” I then opened up the Unreal Engine Project file, The engine created a new “Saved” folder inside my project root folder. I jumped back into the editor and Pressed build and the editor started building my scene immediately.

I also want to mention I am currently using engine version 4.17.1
Thank you @Andrei Despinoiu

That has fixed it for me too! Thanks alot.

double click on your mesh and on the right you will see light map resolution, reduce the light map resolution on the mesh, 1024 is a good quality anything above could stall the light building causing 0% for a very long time. if this is still causing you problems, go thru all your meshes you’ve added to your map and reduce them all.

1 Like

Thanks a lot. I had the same problems.
Solved after deleting “saved” folder.

I deleted my save folder and tried it again and it’s still taking forever… I feel like giving up lol

If you use several (Cards) in one card … Then you need to go into each card separately and build a light inside each card. Or make sure all lights are on the map (Persisten Leve).

Sometimes this happens when lightmaps are too large, or the lightmap override is set too high.
In your Unreal, go to Window > Statistics and sort the list by “Texture LM” so that the largest lightmaps are shown first, clicking them from the Statistics window will select them in the World Outliner and then down in the Details panel, scroll or search for Lighting and either lower the “Overridden Light Map Res” number or use this to override the size of the lightmaps on that particular model.


You are literally the best.