Building light on static mesh does not work

I converted a BSP to a static mesh and when I build the light the static mesh did not pick up the light.

I have generate uv’s on, but it doesn’t affect the outcome.

When I place a pointlight it seems to give of light, but when I build it the pointlight is still there, but it gives of no light.

Hello MrGoatsy,

I am sorry you are having this issue. From what you have described you have created a BSP inside of you scene and then converted that BSP into a static mesh. You then build lighting and the static mesh turns black.

If you would link me a screenshot of your static meshes details panel. You can double click on the static mesh in your Content Browser to bring this up.

BSP’s are calculated differently, when it comes to light map calculations. Typically a BSP has a density of 4. Therefore, whenever you convert your BSP into a static mesh the Lightmap Resolution persists and returns a value of 4. Increasing this to values like 256 or 512 should fix this issue because now you are calculating at a size that is reasonable for a Static Mesh.

Try this out and let me know if this fixes the issue. If it does not then please post screenshots, as mentioned above, and I will continue to investigate this problem at that time.

Thank you,

Here is a screenshot of how it looks:

When I move the light only a bit without building the light again, it will look fixed, but when I build it the issue occurs again.

Change the UV channel from 0 to 1 doesn’t change anything either.

Top bar:

Here are my settings in the details panel:

Hello Mr.Goatsy,

I took a look at your screenshots and I noticed that you have not clicked the apply changes inside of your editor.

Try this and let me know if there is still a problem,

Thank you,

It didn’t change anything and if it did it made it darker.

Hello MrGoatsy,

Sorry to hear you are still having a problem with this. I did a quick test by converting a BSP to a static mesh and this method seemed to fix the issue.

In order for me to test this in completely the same way as you I will need a few files. If you would link me your .uproject, content, and config folders for the project you are having this problem in, then I can attempt to recreate this issue.

Thank you,

I can’t, I have really slow Internet.

I just made a new level, deleted the start block and placed a BSP with the size 500x500x40 and converted it to a static mesh after which I build the light and it was black, I changed the min lightmap resolution to 256, it didn’t change anything, then I changed the lightmap resolution in static mesh sessions to 256 as well and it still didn’t change. I also changed the UV channel to 0 and 1, but there was no difference. I have also deleted the intermediate folder multiple times with no change.

I updated to 4.9 btw and the issue is still there.

I am uploading a test project right now, it was freshly made in 4.9 with the same steps as I described above.

Here is the download link:

Hello MrGoasty,

I believe I have solved your issue. Whenever you are in your details panel of your BSP, scroll down to your Static Mesh Settings. By default there is a tab with an arrow pointing down. Click that. There is a tab for Light Map Coordinate Index tab. Change that from 0 to 1.

This should fix your issue.

Thank you,

Following these steps fixed it:

Is there a way to set it to 1 by default?

In case anyone else has this issue and stumbles upon this page, this solution worked for me when I was having the same issue.

Can confirm, this fixed my issue too. Thanks guys!

Still issue in 4.13 and setting Light Map Coordinate Index to 1 fixes it. In 4.12.5 the same Index bug was causing Lighting build issue (overlapping UVs…).

Is there a way to set the lightmap coordinate index in the scene import blueprint?