Build lighting success, but map still unlit

I’m very new to lighting and tried lighting this hallway w/ 3 stationary lights. First, I rendered in preview mode. Then, I tried rendering w/ medium quality, but my scene still has the “preview” textures and when I start the level, it says lighting needs to be rebuilt. Any ideas here?

Here’s output from the log that shows lighting succeeded:

Job is a success!
Lightmass on RYAN-PC: 3:32 min total, 121 ms importing, 28 ms setup, 2:28 min photons, 1:04 min processing, 0 ms extra exporting [163/163 mappings]. Threads: 4:16 min total, 2:36 min processing.
LogStaticLightingSystem: Illumination: 3:38 min (3.43 sec encoding lightmaps, 838 ms encoding shadowmaps)
LogStaticLightingSystem: Lightmap texture memory:  18.4 MB (18.4 MB streaming, 0.0 MB non-streaming), 160 textures
LogStaticLightingSystem: Shadowmap texture memory: 5.6 MB (5.6 MB streaming, 0.0 MB non-streaming), 79 textures

Strange…instead of just building lighting, I tried building all levels and that seemed to save properly.