Build lighting stuck at 33% on Windows 10


I’ve seen that there are already many questions around that topic in here, but every one seems to be a little bit different, since none of the workarounds or fixes that I have found worked in my case. The actual problem is that every time I try to rebuild the lighting in the editor, Swarm Client launches in the background, but the Unreal Editor gets instantly stuck when the “Exporting light data” dialog reaches 33%. Meanwhile the Swarm Agent appears to be still running, but it’s also stuck at 0% of progress, and the log says:

14:31:28: Starting up SwarmAgent ...
14:31:28:  ... registering SwarmAgent with remoting service
14:31:28:  ... registering SwarmAgent network channels
14:31:28:  ... initializing SwarmAgent
14:31:28:  ......... certificate check has failed
14:31:28:  ...... initializing cache
14:31:28:  ......... using cache folder 'C:/Users/Adrian/AppData/Local/UnrealEngine/4.25/Saved/Swarm\SwarmCache'
14:31:28:  ......... recreating SwarmAgent cache staging area
14:31:28:  ...... initializing connection to SwarmCoordinator
14:31:28:  ......... using SwarmCoordinator on RENDER-01
14:31:28:  ......... SwarmCoordinator successfully initialized
14:31:28:  ...... initializing local performance monitoring subsystem
14:31:28:  ... initialization successful, SwarmAgent now running
14:31:30: [Interface:TryOpenConnection] Local connection established
14:31:30: [Job] Accepted Job 3D7AEAF9-4B0A4845-DC8D45BD-CBEEC4CF

When I faced this problem for the first time, I was using Unreal Engine 4.26, but then I thought that it may be a matter of version so I switched back to 4.25. Unfortunately that didn’t help at all.
I already tried cleaning and veryfying Swarm cache, making sure that the firewall isn’t blocking Swarm client, updating my graphics drivers and so on, but nothing of that worked.
I’ve heard that this bug may be specific to Windows 10 users, but don’t know if that’s true.

I would be very grateful if someone could help me with that :slight_smile: