Download

Build Lighting Problem. Shadow "stains" and other

Hello there!
I built a modular house. But when build the lighting I will have problems:
Снимок.PNG

I use this guid: Why is there shadow splotches on my static mesh?..
But it didn’t help. I clear the stains, when change “Static Lighting Level Scale” to 1. But it create another problem: Modular Asset Lighting Problem

Any ideas about it ?:frowning:

I would reset all of the lightmass settings to default, make sure to build with Production quality. Also, don’t contrust things like the ceiling and walls that way, it is bad for performance and the lighting doesn’t work well with it, instead you will get better results and performance if you construct unique meshes for those.

Thank you very much ! I try to build lighting with default settings and Production quality now. But it is very unusual for me. I watched examples projects, like the room “Realistic Rendering”. It was meshes ceiling,walls and floor. So I thought it was right to combine different meshes into one building. I understand something wrong ?

I have the question, if I try convert actors to one static mesh - it will help ?
I built Lighting with default settings and Production quality.
I have this result.
Снимок2.PNG

Combining the actor into a single static mesh won’t help in this case their unless you make edits to the existing UV for the mesh in an external program, like 3Ds Max, Maya, or Blender. The reason this happens is because the edges are split up and one edge of the UV does not know what the lighting for the other edge is so you get these seams that appear, even if the mesh is a single object and not individual pieces.

It will help to some degree though, the main issue is that each individual object gets processed by itself and so some things like smoothing will be different and cause variations in lighting color. The effect is the most extreme when an object is lit mostly by indirect lighting. But, it’s still better for something like that to be modeled as a single object, it will lower the number of draw calls and the amount of polygons.

I never thought about it before. This is very bad for me because I did a lot of separate meshes. And it was working fine until I used a point light only.
Now I’ve done a lot of experiments. And understand this :

13.png

Am I right ? it is Impossible to build two walls as one.
But I have some results with modular room. I created a clean project and only used the Starter Content Meshes. I added a little point light and changed Static Lighting Level Scale:

12.png

It work, but I’m sure that is a bad way. It’s sad, because build modular building like this is very conveniently and fast. Thank you very much for all help !

Thank you! I already tried and sure in this :slight_smile: I read this guide but alas it not helped me. I wrote above that I think about it.

So, the major performance issue in working with modular building houses is the number of draw calls and the amount of polygons?

Regards,
Lucas Martins.

how i can import the plugin Pls help me !!!

Modular workflow will save on memory, but for things like a wall the mesh is not very complex at all so the amount of memory you save is not worth it and the draw calls will have a much greater impact. These days games can have very high polygon counts and it’s usually better to use more memory than to increase draw calls. Eventually this lighting issue won’t be an issue in UE4, but draw calls will always be a concern. For an interior I usually have the walls of each room as a single mesh. Just remember that you can only use one lightmap for an object so you can’t combine too much or you won’t be able to make the lightmap high enough to get the detail you want.

Hi!

Just a few questions:

  1. Do you have portals at your windows/doors?
  2. Do you have LightmassImportanceVolume/LightmassCharacterIndirectDetailVolumes covering your building/room?

Environment intensity I would leave on default!
And I wouldn’t use compressed lightmaps!!

Good luck!!

https://www.youtube.com/watch?v=3TqQH1fZAtM
Check This out.

Last resort: be sure your uv grid for each element is snapped to 1/target lightmap resolution, then use this UV as your lightmap target. So 1/64 = 0.015625, make your UV grid snap to units of 0.015625. When you have UE4 generate your maps for you on import, I believe it tweaks your map to fix this, but I’ve never been 100% sure. Included photo of how to set this up in Maya.

…well there is (at least) one solution for modular pieces:

  • indirect lighting scale (in world/lightmass setting) 0.1
  • indirect smoothness 0.6
    With this you can get rid of the seams between modular pieces…