Download

Build lighting keep stopping at 99% - Help

When I built the lighting on production/high quality, it stops at 99% and doesn’t move. I even left it for like 45 minutes. I’ve restarted my computer a few times and that hasn’t worked either. Building the lighting at medium works though.

Is there actually much a difference between medium and production? If there isn’t I might not be too worried about it

Thanks

If you never succed to build the light, it could be your Antivirus blocking the Swam Agent who render the light, i had this issue when i begin with UE4 ^^.

Also make sure that you start the UE4 with admin rights and probably wait a little bit longer (open the swarm and check if the bars are still moving)

Usually this means there is a single object with a high lightmap resolution that makes it take an enormous time to process. Sometimes it is another property, like having a huge scale in the world.

After your successful medium quality build, you can look at the lighting build times for the meshes in your scene and see which took the longest. IIRC it’s under Build->Lighting info ->Static mesh lighting Info and then change the tab to lighting info.

it took me almost 5 hours to complete with all quality settings at maximum reflexes and effects

Intel Core I5 GTX 1060 6GB 12GB RAM

relax because it takes time

check the task manager if ue4 uses 60% or more of your CPU.

this is a 4 year old thread