Build lighting cpu cores

Hi , I have a phenom x6 100t cpu, when I build lights the swarm works only with one core? Why? Any help will be appreciated, thank you

Hi Missu,

You can check to see how many cores are being used by having a look by using the Developer Settings in Swarm Agent.

The processor count should be set to 1 or 2 less than the number of cores that you have available. This value does not change on the fly either.

When you’re looking at the Status windows where you can see the light build being processed you can visually see all the cores being used by going to the Settings page and in the AllowedRemoteAgentNames and set the name to be RENDER*

This will enable the individual cores being used to show their progress.

I hope this helps.

Tim

Thank you Tim Hobson, I uninstalled unreal and reinstall…now is ok I can see 4 cores from 6, but now if I want to work with all six cores how do I do? in previous versions in BaseLightmass.ini I can change the number of cores but in 4.9 there is no option for that. Thank you anyway

I’m not familiar with this originally being set in the BaseLightmass.ini. That may have been the case at one point, but I’m not sure that stands anymore. I just compared the 4.9 to the 4.7 ini and see no differences, so if it was well over a year ago at this point.

You can set the number of cores used by Swarm Agent using the method above though.

In lightmass.ini is a parameter called NumUnusedLightmassThreads i think, at line 21 i guess

hi

even we face this issue with 4.11.5. all cores are not being used at end of baking. if anyone have any fix please let us know…

thanks
jose

Not all cores are used all the time. This is normal. When cores aren’t being used they are waiting for others to finish before proceeding and sometimes there isn’t anything for them to do since they don’t all work on the same actors. This is why you get slight shading differences between some planar faces of different static actors in your scene.

thank you Tim… :slight_smile: