Build Geometry mess up every material into the map

EDIT: [FOUND A HALF SOLUTION] - When build, set the alignment of all the materials placed on the map to “Align Surface Default”, if it doesn’t work, set the alignment to “Align Surface Fit” and then reset it to “Align Surface Default

EDIT: I found another topic that talked about this problem, IT IS ACTUALLY A BUG! That’s the CODE OF THE BUG: UE-11368

First of all… these are the assumptions for my map:

  • It is an imported t3d. (EDIT: It doesn’t happen only with imported BSPs, but with the new BSPs too).
  • I scaled it to x100 y100 z100 (cause it was small like a foot of a standard character).
  • I did put a Lightmass Importance Volume covering all the map.

So, the problem is that when I Build, or just applying a Build Geometry, it mess up every material of my map,
also, I can’t even pan and scale the material anymore after that.
With mess up every material I meant that they become a lot pixellated.
EDIT: I tried setting the detail of the texture to “NoBitMap”, it works but, when I build the geometry, it resets all the textures, even if I scaled them or rotated them or whatever.

Here the screenshoots:

  • Before reduild:

  • After rebuild:

  • Trying to rebuild a second time:

  • Trying to rescaling the applied materials:

p.s. Already tried with restarting the editor.

Hey Francesco Biscazzo -

The t3d file that you imported, was it from UDK (UE3)? If so, there are some major differences in how the two engines handle the BSPs. One of which is how UVs are handled which would explain why when you told the UE4 to rebuild the Materials seemed to change and stretch but the vertices did not.

Thank You

: I imported it from Unreal Editor 2.0 , the one of the old Unreal Tournament

EDIT: And anyway, it doesn’t happen only with imported BSP, but new BSP too, I’ll add this on the main post.

Hey Francesco -

Ok, so my first suggestion is to use the layout that the t3d gave you and actual rebuild the map from scratch in UE4. I want to make this my first suggestion as it will give you a chance to really learn the new aspects of the engine and create something that you already know how it works, so the learning is all about the tool and not the level design.

The key issue is that you have turned in several BSPs from UE2 to one giant and BSP in UE4 and the unwrap of the mesh is all over the place which is causing the scaling and material issue you are responding.

Besides rebuilding the level, you can try to convert the BSP into a Static Mesh and then export it to a modeling program to unwrap and then bring it back into the engine.

Thank You -

I already tried with converting it into Static Mesh, nothing changes :confused: But I don’t know what you meant with “exporting it to a modelling program to unwrap”.
By the way: I saw that the NoBitMap actually works, I just didn’t save the texture.

But still… the geometry buil reset every material, even if I, or example, rotated the materials :confused:

Hey Francesco Biscazzo -

I have added your information to our internal bug report as you mentioned above, UE-11368, and will keep you informed as we work toward a solution.

Thank You

Hey, thank you very much!
I finished my map, that’s the last of 2 issues I encountered.

I wanted to say that the problem still persists. Did you find any solution?

What version of the Engine are you in ? This issue was resolved in the 4.7.4 Hotfix. If it is recurring for you, please give as much information about your engine version and setup as possible.

Thank You -

I couldn’t of install the 4.7.4 version because it didn’t work on my old laptop, now I’ve a new one and so I downloaded this version using the official launcher: version 4.8.0-2739211+++depot+UE4-UT-Releases

I’m not so sure, but I think the problem does now appear even building light only.

Hi -

We are currently unable to reproduce this issue in the most current version of the Editor or in the version of the UT Editor you mention above? Can you attach a sample project here for us to test on?

Thank You

You’re correct, but my map still has that problem, so I thought it was related to the t3d I imported time ago, I tried reimporting it into a blank map, but I couldn’t, I don’t know why, If you tell me a place where to send the t3d file, I’ll try to do it.

Just place the t3d in a and then attach it here. If it happens to be over 5MB, then you can share a google drive or dropbox link here.

Thank You -

The t3d is around 36Kb, I zipped it but nothing, the attachment is not valid, I’ll share it with dropbox: Dropbox - Error - Simplify your life

It is a t3d file I exported using Unreal Editor from Unreal Tournament (1999)

Hi Francesco,

Unfortunately I was unable to use the .t3d files that you posted here. Does this occur in a clean, blank level with no additional content or is it limited to one level/set of bsp brushes?

Mainly only BSP Brushes. I placed only four standard cubes as static meshes, but I didn’t check if the materials get messed on their surfaces.

Try creating a brand new level and place a single bsp brush within the level to try and see if the material error occurs when you use the build geometry. Are you seeing the same error occur in this scenario?

I just placed a BSP cube inside the map I showed in the first post, and that BSP cube is not affected by this bug. Plus, I tried creating a new empty map to import the t3d file, and yes, the import doesn’t work with that t3d now. But it worked when I created this topic, on that Unreal Editor version.

Hi Francesco,

Unfortunately, UE4 is not intended to support files from previous engine iterations. While it may have been able to be imported in a previous engine version, this was more by chance than intended functionality. I am happy to hear this issue does not occur for you with other bsp brushes or files. I am marking this as answered for tracking purposes. If you experience this error again with BSPs outside of this file, please feel free to re-open this thread and we’ll continue looking into it.

Oh ok, thank you for your support, I’ll try to replace all the old BSP brushes with the newer ones :).