Build Failed Unknown Error when bEnabled=true

Hi, guys. I’m trying to use the OnlineSubsystemFacebook plugin but I’m getting Build Failed everytime the key bEnabled=true in the section [OnlineSubsystemFacebook] inside of DefaultEngine.ini. Every other key or section involved with [OnlineSubsystemFacebook] doesn’t affect the build.

When bEnabled is commented out, is false or if it doesn’t exist in that section of the ini file, the packaging will proceed. But, of course, the facebook functionality also doesn’t exist.

MinSDK is 21

TargetSDK is 23

What I’ve tried, so far (but still doesn’t work):

-uninstalling and installing UE4.16.3 from the launcher

-uninstalling and installing SDKs from chooser.exe

-creating a new project and applying it there

-using either facebook-android-sdk-4.25.0 and 4.19.0. Location is at UE_4.16\Engine\Plugins\Online\OnlineSubsystemFacebook\Source\ThirdParty\Android\NotForLicensees\FacebookSDK\facebook-android-sdk\4.19.0\

Here are the steps I made in creating a new project:

  1. Created project for mobile and scalable 2d
  2. Edited project Settings (Supported platform to Android only, package name to my package name “com.Horizon.Brick”, minSDK, target SDK, NDK and SDK API level, added keystore of my game, clicked “configure now” in APKPackaging)
  3. Saved NewMap and selected in ProjectSettings > Maps & Modes > Editor Startup Map and Game Default Map
  4. Enabled “OnlineSubsystemFacebook” on plugins
  5. Added required sections and keys on DefaultEngine.ini
  6. Restarted engine
  7. Packaged for ETC1

Here is the output log I’m getting: [link text][2]

Here is a screenshot of my SDK settings:

These are the additions to DefaultEngine.ini


ClientId=<My Facebook App_id here>




I’m guessing it has something to do with OnlineSubsystemFacebook_UPL.xml when creating the AndroidManifest tags. Can anyone help me?

Bump. Please help.