Download

Build error on Linux 20.04.2 and ue5-main : remote_execution.pb.h not found

I receive the following errors when I try to build UnrealEngine from a clean pull on the ue5-main branch. There are more errors, all related to this remote execution. I’ve scoured the internet but can’t find a solution.

UnrealEngine/Engine/Source/Editor/Experimental/BazelExecutor/Private/ProtoConverter.cpp:13:10: fatal error: 'build\bazel\remote\execution\v2\remote_execution.pb.h' file not found
UnrealEngine/Engine/Source/Editor/Experimental/BazelExecutor/Private/BazelCompletionQueueRunnable.cpp:11:10: fatal error: 'build\bazel\remote\execution\v2\remote_execution.grpc.pb.h' file not found
UnrealEngine/Engine/Source/Editor/Experimental/BazelExecutor/Private/BazelExecutor.cpp:13:10: fatal error: 'build\bazel\remote\execution\v2\remote_execution.pb.h' file not found
1 Like

Could you switch to the ue5-early-access branch? ue5-main is too bleeding edge. Most of the time will not compile and is not ready for use. You might be better off with early access branch.

If you still insist on using this branch then I can do a commit to a fork, and pm the link to github repo. At present the hack is an out of tree patch and I can’t paste it here without violating eula.
Welcome to the unreal community!

Hello sam.new. Thank you for the welcome, and for the suggestion! I switched to the ue5-early-access branch, and went through all the steps again (Setup.sh, GenerateProjectFiles.sh, make). Unfortunately, I now run into a new error, which seems to be originating from Clang. Since the repository ships its own version of Clang, I’m unsure what to do here…

Running command : Engine/Binaries/DotNET/UnrealBuildTool/UnrealBuildTool UnrealLightmass Linux Development
Linux using Manual SDK v17_clang-10.0.1-centos7
Using 'git status' to determine working set for adaptive non-unity build (/media/h1/UnrealEngine).
Creating makefile for UnrealLightmass (no existing makefile)
Parsing headers for UnrealLightmass
  Running UnrealHeaderTool UnrealLightmass "/media/h1/UnrealEngine/Engine/Intermediate/Build/Linux/B4D820EA/UnrealLightmass/Development/UnrealLightmass.uhtmanifest" -LogCmds="loginit warning, logexit warning, logdatabase error" -Unattended -WarningsAsErrors -abslog="/media/h1/UnrealEngine/Engine/Programs/UnrealBuildTool/Log_UHT.txt"
Loading text-based GConfig...
Reflection code generated for UnrealLightmass in 0.6808699 seconds
Building UnrealLightmass...
Performing 66 actions (12 in parallel)
[1/66] Compile PCH.Core.h
[4/66] Compile Module.TraceLog.cpp
[2/66] Compile SharedPCH.Core.ShadowErrors.h
[3/66] Compile PCH.CoreUObject.h
[6/66] Compile SharedPCH.CoreUObject.ShadowErrors.h
[5/66] Compile BuildSettings.cpp
[7/66] Compile Module.UnrealLightmass.3_of_3.cpp
[9/66] Compile Module.UnrealLightmass.1_of_3.cpp
[8/66] Compile Module.UnrealLightmass.2_of_3.cpp
[10/66] Link (lld) libUnrealLightmass-BuildSettings.so
[11/66] Compile Module.Core.10_of_16.cpp
[12/66] Compile Module.Core.3_of_16.cpp
[13/66] Compile Module.Core.1_of_16.cpp
[14/66] Compile Module.Core.16_of_16.cpp
[15/66] Compile Module.Core.2_of_16.cpp
[16/66] Compile Module.Core.8_of_16.cpp
[17/66] Compile Module.Core.12_of_16.cpp
[18/66] Compile Module.Core.15_of_16.cpp
[19/66] Compile Module.Core.11_of_16.cpp
Stack dump:
0.	Program arguments: /media/h1/UnrealEngine/Engine/Extras/ThirdPartyNotUE/SDKs/HostLinux/Linux_x64/v17_clang-10.0.1-centos7/x86_64-unknown-linux-gnu/bin/clang++ @/media/h1/UnrealEngine/Engine/Intermediate/Build/Linu x/B4D820EA/UnrealLightmass/Development/Core/Module.Core.11_of_16.cpp.o.rsp
 #0 0x0000000001931efa llvm::sys::PrintStackTrace(llvm::raw_ostream&) (/media/h1/UnrealEngine/Engine/Extras/ThirdPartyNotUE/SDKs/HostLinux/Linux_x64/v17_clang-10.0.1-centos7/x86_64-unknown-linux-gnu/bin/clang+++0x1931efa)
 #1 0x000000000192fce4 llvm::sys::RunSignalHandlers() (/media/h1/UnrealEngine/Engine/Extras/ThirdPartyNotUE/SDKs/HostLinux/Linux_x64/v17_clang-10.0.1-centos7/x86_64-unknown-linux-gnu/bin/clang+++0x192fce4)
 #2 0x000000000193060d SignalHandler(int) (/media/h1/UnrealEngine/Engine/Extras/ThirdPartyNotUE/SDKs/HostLinux/Linux_x64/v17_clang-10.0.1-centos7/x86_64-unknown-linux-gnu/bin/clang+++0x193060d)
 #3 0x00007ff19ffaf3c0 __restore_rt (/lib/x86_64-linux-gnu/libpthread.so.0+0x153c0)
 #4 0x000000000085ece6 _init (/media/h1/UnrealEngine/Engine/Extras/ThirdPartyNotUE/SDKs/HostLinux/Linux_x64/v17_clang-10.0.1-centos7/x86_64-unknown-linux-gnu/bin/clang+++0x85ece6)
 #5 0x00000000016be346 llvm::opt::OptTable::ParseOneArg(llvm::opt::ArgList const&, unsigned int&, unsigned int, unsigned int) const (/media/h1/UnrealEngine/Engine/Extras/ThirdPartyNotUE/SDKs/HostLinux/Linux_x64/v17_clang-10.0.1-centos7/x86_64-unknown-linux-gnu/bin/clang+++0x16be346)
 #6 0x00000000016be655 llvm::opt::OptTable::ParseArgs(llvm::ArrayRef<char const*>, unsigned int&, unsigned int&, unsigned int, unsigned int) const (/media/h1/UnrealEngine/Engine/Extras/ThirdPartyNotUE/SDKs/HostLinux/Linux_x64/v17_clang-10.0.1-centos7/x86_64-unknown-linux-gnu/bin/clang+++0x16be655)
 #7 0x00000000008dbc61 main (/media/h1/UnrealEngine/Engine/Extras/ThirdPartyNotUE/SDKs/HostLinux/Linux_x64/v17_clang-10.0.1-centos7/x86_64-unknown-linux-gnu/bin/clang+++0x8dbc61)
 #8 0x00007ff19fa700b3 __libc_start_main /build/glibc-eX1tMB/glibc-2.31/csu/../csu/libc-start.c:342:3
 #9 0x0000000000948bf5 _start (/media/h1/UnrealEngine/Engine/Extras/ThirdPartyNotUE/SDKs/HostLinux/Linux_x64/v17_clang-10.0.1-centos7/x86_64-unknown-linux-gnu/bin/clang+++0x948bf5)
[20/66] Compile Module.Core.6_of_16.cpp
[21/66] Compile Module.Core.14_of_16.cpp
[22/66] Compile Module.Core.7_of_16.cpp
[23/66] Compile Module.Core.4_of_16.cpp
[24/66] Compile Module.Core.9_of_16.cpp
[25/66] Compile Module.Core.5_of_16.cpp
[26/66] Compile Module.Core.13_of_16.cpp
[27/66] Link (lld) libUnrealLightmass-TraceLog.so
[28/66] Compile Module.Json.cpp
[29/66] Compile Module.Projects.cpp
[30/66] Compile NetCommonModule.cpp
[31/66] Compile Module.CoreUObject.gen.cpp
[32/66] Compile Module.CoreUObject.3_of_9.cpp
[33/66] Compile Module.CoreUObject.8_of_9.cpp
[34/66] Compile Module.CoreUObject.6_of_9.cpp
[35/66] Compile Module.CoreUObject.5_of_9.cpp
[36/66] Compile Module.CoreUObject.7_of_9.cpp
[37/66] Compile Module.CoreUObject.4_of_9.cpp
[38/66] Compile Module.CoreUObject.2_of_9.cpp
[39/66] Compile Module.CoreUObject.9_of_9.cpp
[40/66] Compile Module.CoreUObject.1_of_9.cpp
[41/66] Compile Module.Sockets.cpp
[42/66] Compile Module.Networking.cpp
[43/66] Compile Module.Cbor.cpp
[44/66] Compile Module.Messaging.cpp
[45/66] Compile Module.Serialization.gen.cpp
[46/66] Compile Module.Serialization.cpp
[47/66] Compile Module.SwarmInterface.gen.cpp
[48/66] Compile Module.UdpMessaging.gen.cpp
[49/66] Compile Module.UdpMessaging.cpp
[50/66] Compile Module.ApplicationCore.cpp
[51/66] Compile Module.SwarmInterface.cpp
make: *** [Makefile:898: UnrealLightmass] Error 6

Could you tell me the distro that you are using?
Have you installed the build essential or similar for your distro ?

Possible issue is that clang downloaded and installed by running ./Setup.sh is corrupt.
#delete these files using file browser
UnrealEngine/.git/ue4-sdks/v17_clang-10.0.1-centos7.tar.gz
go to UnrealEngine/Engine/Extras/ThirdPartyNotUE/SDKs/HostLinux/Linux_x64/
#delete any clang folders like below
v17_clang-10.0.1-centos7

#From console ‘with internet on’ (to download clang again and dependencies possibly)
./Setup.sh
#To download nuget and .net 3.xx
./GenerateProjectFiles.sh

#Then to make sure things are working correctly we will only build ‘Unrealightmass’
#input:
make ARGS="-clean" UnrealLightmass
#Then:
make UnrealLightmass

#See if that was successful run
make ARGS="-clean"

#then build the engine completely make

I ran all your instructions to the letter, with the added step that I also purged anything related to v18_clang, which was in the same folders as v17_clang. After running all the steps, UnrealLightmass compiled! Somewhere further down the compiling process, Clang once again ran into an internal error. This time, I simply reran “make” and the error didn’t pop up again. So now, I’m not certain if ‘refreshing’ clang actually fixed it, or if simply rerunning “make” was the fix.

In any case, your steps helped me solve the problem. After looking to the UnrealEngine splash screen for the last 20 minutes, it has now booted! Thank you for your help.

On an offtopic note; My UnrealEngine folder is currently 128GB large. The docs note only a 20GB requirement : You will also need at least 20 GB of free disk space and a relatively powerful machine.. The .git folder is around 30GB, and the Engine folder around 100GB. Is this expected, or am I doing something wrong on my end?

Thanks again.

1 Like

For reference my fresh build of the ue5-main branch when compiled is 162GB total size (Windows 10).
This was cloned and built fresh today so your numbers look about right (in fact better than mine LOL).