Download

Build error for Android with Google VR and sign [4.14.1]

I have tried to package my Cardboard Project and then try to upload to google play but it only package when I don’t sign it. I have followed the specific guide https://docs.unrealengine.com/latest/INT/Platforms/GoogleVR/QuickStart/index.html but it doesn’t work with that specific NDK, SDK, apache, JAVA and android-21 in both (sdk and ndk).

I have my own firm (.keystore) in the correct folder and I have done a signed project succesful but when I change to VR It doesn’t work.

I am a little desperated because I have tried everything (change to newest versión of NDK, java…) and even trying solutions of other posts but it does not work for me. Also I have written a post there Fail to package Google VR cardboard and sign it - UE4 AnswerHub but solutions I receive doesn’t work.

I have seen in other posts that with google VR is better to choose android-24 but it does not work neither.

I attach my log file and caps about my configuration.

I think that the problem is with the API 24 in this log line (D:\NVPACK\android-sdk-windows ools\ant\build.xml:871: Can’t read [D:\NVPACK\android-sdk-windows\platforms\android-24\android.jar]) but I have got installed eveything about API 24 in the SDK.

Only one more thing…I think that the specific guide is a little obsolete…so I would like to know what is the best selection in the configuration to build with Google VR for android and sign it.

Thanks a lot and sorry about my english if there is something wrong.

Are you using the new Codeworks for Android 1R5 from 4.14 Engine/Extras/AndroidWorks? It has a new version of Proguard which should fix this error:

D:\NVPACK\android-sdk-windows ools\ant\build.xml:871: Can’t read [D:\NVPACK\android-sdk-windows\platforms\android-24\android.jar] (Can’t process class [dalvik/annotation/TestTargetClass.class] (Unsupported class version number [52.0] (maximum 51.0, Java 1.7)))

Ohhh my god…I want to die after one week installing everything possible, reading a lot of post and because not being an annoyance maybe asking the same question… It has worked.

Thank you very much. I successed to build it but in lower versions of Unreal.

Only one more little question. I have this annoying message when I start the launcher and I try to run Unreal.

I have solved it running directly the Unreal from the folder but the executable with -cmd.

Is there any way to solve it? (I know that maybe it is not the correct place of the forum to answer this)