Build engine from source error[SOLVED]

hi guys im trying to build the engine from source. i downloaded the zip file , exstracted it. when i run setup in order to download the dependencies it gets all the way to 99 % which takes ages then fails with this error. it happens everytime . ive tried re downloading the files but it still happens.

i have tried forking and cloning the repository instead and got the same error. it seems as though a file is missing??? can anyone help please


ok for anyone having this issue it is to do with the antivrus getting a false positive result and thinking some of the unreal binary files are a trojan virus. After realising this was the problem i closed down my antivirus and tried to install from source again but still i got this error.

it turns out even when my antivirus was closed it was still running background processes and tasks in the background. So i just ctl alt del and went to my task manager and ended any processes i could find with my antivirus name in it and have now succesfully built the engine from source.