Download

Build button is greyed out

My build button for building lighting is greyed out. How do I fix this?

You can not build light if you have the level preview option enabled. You can only build light when your viewport is set to SM5.

HM I SO need to start taking notes on some changes o_0: I do have Sm5 enabled under preview rendering as ue4 is forcing shader compile of 16,600 , so I can’t check atm , and I also have build lighting greyed out.

OK found it on start of editor, as myself, you probably have enabled ‘Force no precomputed light’ under world settings. Disabled, build lighting is no longer greyed out.
Hope that helps.

I have the same problem, I tried it with ‘force no precomputed light’ on and off but it seems like it does not change a thing. Where do I see if the level preview is enabled?

Pretty sure he means ,Editor top menu>Settings>Preview rendering level, which yes is where you set SM5 or such.

Yes my settings were right at this point but I had “Allow Static Lighting” in my project settings disabled…

So the solution that works for me is with “Force no precomputed Light” disabled and “Allow Static Lighting” enabled just in case someone else rans into this problem.