[BUG] VR Spectator Screen show only part of what it needs to

I’m following the simple setup described here for having a full-width 1920x1080 VR spectator screen: https://www.undeaddev.com/simple-vr-spectator-camera/.

I have a Scene Capture Component 2D, a Render Target, blueprint nodes setting the spectator screen mode and texture, the whole shebang. Despite all this, I can tell the spectator screen that pops up is “zoomed in” or cropping most of the image off my screen so I can only see the center of what’s in view. I remember this working a lot better in previous versions of the engine on other projects so this behavior is new to me.

Game Mode event graph:

Scene Capture Component config:

Render Target config (you can see here how wide and nice the image is supposed to look):

Game viewport settings:


And finally what the spectator screen looks like during VR preview (that’s my Pawn after it spawns to the left of the ramp shown before):

You can see in the above screenshot that the image is way more zoomed and pixelated compared to what the render target preview shows. Why is this happening, and how can I fix this?

I just noticed this “zoom in” seems to happen no matter what the spectator screen mode is. When I set it to show what the HMD is seeing, it’s way more zoomed in/cropped than what the headset is seeing, no matter what setting I set it to.

For example, this is what the spectator screen looks like when I set the mode to SingleEye:

I’m using an original HTC Vive if that matters, with SteamVR 1.13.10

I get this too since 4.25.2? Any work-arounds?
For me it’s ok in the editor sometimes, always off when packaged.

That’s an interesting find. Hopefully an Epic employee can provide some insight here.

Same problem here on 4.25…Editor as well.

same problem with vive pro and editor’s viewport - zoomed in/cropped view.

Thanks! I’ll try that next time I’m developing and will report back if I have any further issues in 4.25.


I believe we have fixed this for 4.26.

There is a workaround, if you make an “r.setres 1280x720” (or any resolution) call after stereo rendering starts the spectator screen will look right.

The attached zip contains diffs of the files that changed. Just a few lines in each one.
link text

I just did something similar and was about to post the answer here :). I set the resulution to 50 percent inside SteamVR settings and that worked too. But with mine the viewport has to be launched in windowed mode and manually clicked to full screen icon.

Thanks worked for me!

Looks like it was fixed for 4.25.3 or 4.25.4, thanks!