[Bug] Vertex anim tool

Since this will probably go directly to Tim H.

When you process the Animated Meshes, the newly generated mesh (the one you export) doesn’t contain all the UV-channels created for the initial meshes.
This means any UV map besides the first one are ignored.
Any way you can change this? I got a whole setup going on that kiiiinda relies on this :confused:

Copy/Pasting the existing uv-maps into the new mesh dont always work properly either :frowning:

Hey Yoeri,

Sorry, this one fell by the wayside for a while. Entered UE-35235 for this one to be added in the future.


Hey Jon, I attached the source Max file to the JIRA for you.


Could you send me some files that demonstrate the problem?

My email address is Jonathan.Lindquist@epicgames.com

heya guys, I dont think its a bug, just a limitation in how the plugin was written.
If a mesh has more than the regular uv-map/lightmap uv. (two channels) it will overwrite any additional channels with the channels normally used for the vertex animation.

Yes, it can be avoided by not using the channels assigned by this tool, but I personally would prefer an option in the 3dsmax tool to assign the uv-maps.
(would benefit workflow)


The ticket was entered as a feature request. From Jon’s comments in the JIRA it may be a naming issue with how Max/Maya names the UVs but Unreal names the UVs itself.

Awesome :slight_smile: please keep me updated!

I’ve made the alterations that you’ve requested but the changes will not be in the public build for months.

You can make a few alterations to the material function in addition to running the new script that I’ve attached to enable the feature.


A texture coordinate dropdown box has been added to the scripts ui. It will dictate where the procedural uvs are placed.

Within the material function you will need to make an adjustment. Replace the texture coordinate circled above with a material function input. The input should be a float 2 and with a label indicating that it’s for morph target uvs. The texture coordinate that you use there should match the uv coordinate that was used when the vertex animation script performed it’s function.

Let me know if everything works out.

(Here is the new script)

[link text][3]

Hey Jonathan, first of all…
Thank you so much for going out of your way and adding this feature.
Its really appreciated.
Glad you added the UV-channel to the exported exr name!
Though, to avoid some confusion it might be wise to -1 the uv-output name to match the ue4 uv channels.
(uv5 is uv4 in ue4)

I have checked the script, the mesh it outputs and the edited mat function and both work as intended.
What did strike me as odd though, and I cant find the reason for it…
Is that even without changing the UV channel in the newly created float2 input to the right channel (I used channel 5 in this case) the mesh animated correctly.

Maybe its because I used a simple 72 polygon cube without much complex animations… or something else is happening.

Oh god, its another weird 3dsmax/ue4 fbx bug.

My steps:
Created cube, 9 polygons each side.
I created 8 uv-channels.
Animated the cube.
Set the UV-Channel to 5 for the vertex animation script.
Imported the cube it created.
Only has 4 uv-maps, and the 2nd one (uv1) is the uv created by the script.

Going to retry from scratch again.
(Seriously though, I dont know if its max or ue4, but last few months have been nothing but headaches with fbx)

More Edits:

Seems to work this time, I blame 3dsmax as usual :slight_smile:

Ha yeah, thanks for the comments. I thought about that inconsistency as well. I’ll go ahead and drop the uv count on the texture name.

The inconsistency can be a bit confusing at times.