[Bug report] No transformation gizmos with mobile preview on

The yellow outline for selected objects and transformation gizmos are disappearing after activating mobile/HTML5 preview mode.

Engine version 4.7.2, run from the launcher.

Hello rimau,

Thank you for your ticket. This is the expected behavior of the engine. when you use the mobile preview, it gives you a preview of what the game will look like when it is running on a mobile device. the gizmos and yellow lines for selections are only present in the editor. If you would like to see what your game is going to look like and still have access to the editor functions select “simulate” from the drop down next to the play button.

32678-simulate.png

Hi

It seems that I need to be a bit more specific. This is the normal editor view:

And this is the option I was writing about (Project and Editor settings → Preview Rendering Level:

The same element is selected on both screenshots. Only rotation gizmo works normally in the second mode.

Hello rimau,

I understand now, and I apologize for the confusion.
The issue that you are facing is known and a bug report has been entered at UE-6458. This issue is being worked on and I have added myself to the list of people watching this bug so that when changes are made, I will be informed and then I will make sure to pass that info along to you.Hopefully we can get your issue worked out soon.

Thanks for your patience,

Benjamin Hyder

Can you re-open please. Transform gizmo is not visible in editor when switching to mobile preview. So when trying to edit a level with mobile preview enabled one needs to constantly switch back and forth between preview modes when wanting to move an object. Clearly not desirable and not expected behavior. Also would be nice if preview mode was saved between editing sessions. When working on a mobile game it would be nice to not have to constantly switch the preview mode - whenever starting the editor and whenever one wants to move an object.

Hi rogerfreedom,

A resolved issue simply means that we are aware of the issue and we have a bug report in our system. We’ll make sure to post here when we see any update on the bug.

Hi, Still I have from time to time this issue. After delete all cached and temporary files like Intermediate this problem seems to be solved but only for a while, because after some time the translate gizmo is disappears again. UE 4.10.1 (release version).

R&D Lab,

Could you please provide me the exact reproduction steps to make this happen? I am unable to reproduce this based on the information that was provided earlier in this thread.

Thank you!

For me this also happens, but only when the Mobile HDR option is turned off, turning it on will make it work.

I’m having this problem as well (in 4.12.2)…and we’re currently working with Mobile HDR turned off as well.

I see the issue is marked as Won’t Fix. From the title, I’d agree that it can’t be fixed as the selection outline is a complex post-process.

But the biggest issue is being unable to see the move gizmo.That’s a bug, IMO.

I am able to see the move/scale/transform gizmo within the editor in ES2. If you are not able to, please open a new question in AnswerHub for additional assistance. Feel free to link back to this question as reference in your new post.

Thanks!

Can you see it if you disable Mobile HDR? It’s kind of a priority item as switching back and forth between Shader 5 and ES2 takes a bit of time to recompile shaders…and it’s impossible to move anything around without the gizmo

Yes, I switched between them with Mobile HDR both on and off and I was able to see them.

You may want to submit a new thread if you’re not seeing this in 4.12.5 or 4.13.0 preview 1.

Thank you!

We are also having the same issue, it didn’t matter if we have Mobile HDR turned on or off in the project settings. At no point do we ever see transformation gizmos in Mobile Preview. As mentioned Akira3d, switching back and forth is incredibly time consuming, and not really a fix. This is occurring in 4.12.5.

I am in 4.13.0 Preview 2 (I’ve already updated) and I have not had an issue with the gizmo. I’ve created 2 new projects to check it in.

Thanks!

This is still happening in 4.13, even in the new high-end mobile preview rendering mode.

Note:

  • The move gizmo is completely invisible
  • Rotate gizmo IS working (not sure if this was true in 4.12.2)
  • The scale gizmo only renders the triangle, not the axes or boxes

NEW INFORMATION. PLEASE SEE BELOW! (10/26/2016 POST)

Well, that’s interesting… after additional testing, I can confirm this is a severe bug. When I tried this on a tiny project that had already “glitched” and the widget would not show, now I am unable to get it to show at all even by following my own “fix” above. Even manually exiting the launcher from the Windows taskbar and reopening the project won’t fix it.

I actually have Combined Static and CSM Shadowing disabled in my project