BUG REPORT: Material Transparency Broken in 4.13?

This is a 4.13 issue. Got the promoted from git last Thursday. After some excitement i built out a GearVR Project and…

Any transparency / transparent material will not render in project build.
did some testing and All Transparent Materials are Broken.

In PIE all is fine when played in window. transparency works. But not after build.

My target project is for GearVR - Android.
I have been using 4.11 and have not any issues before with transparencies.
Will not be using 4.12 as I am wanting the use of the VR templates in 4.13

I have rebuilt engine 3 times over the weekend and each time same results.

After sent to GearVR objects are in world but completely transparent. not matter what percent. 100 to 0 all become invisible. All Engine pre made transparent materials do the same.

I have not built a PC project as a PC build yet since my target is for GearVR.

Was told to report here…

i did keep getting this in which I thought might be a key to some problems…

the lines in yellow about ‘Log Render Warning Mismatch between bShouldGenerteLowQualityLightmaps has been depreciated’

argh… anyway hope this info is a start.

any help is gonna be greatly appreciated. can not live without transparencies.

Hello ,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?
  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?
  3. Could you provide screen shots of any blueprints/materials that may be involved?
  1. When i had the first promoted from last week on 21-22nd. I had reproduced it a few times building and testing different settings and built and sent over to android. All with same results, no transparent material settings rendered… no matter what value. I did nothing special after realizing what was happening… Since i am VR hungry, i tested Widgets first off and noticed opaque and masked worked but transparent was gone. then i noticed the logo on floor with text and the spinning green icon were gone too… they have transparencies. 1 and 1= so…
  2. Don’t have to do much, just load example map and load a transparent material, render build send to android gearvr and it will not show up… Object will exist, collision and all but invisible.
    Since then i have been updating and trying new engine builds. and now encounter even weirder issues. I have been updating and trying new promoted builds and as of this stage, I can not get it to build a project that actually plays now. it just closes out project on android in DevMode for GearVR. White screen. then minimizes. plus on the second engine build i noticed extreme stickiness when clickin gon objetc in editor and noticed a CPU spike each time all the way to max. which does not stop…
    (note: have been spitting out 4.11 builds all the time, well aware of new engine needing osig, and have made sure all basic settings are followed to get it out as build to android)
  3. this point no, and as is I didn’t do any custom materials except duplicate the cube material and make it transparent. I moved on to the latest promoted from yesterday and now it wont even finish building engine this time to test it.
    So unless there is some new configuration in project settings i have to follow, or get (what Ive been thinking might be wrong, an updated new NDK pack from NVIDIA since all those new options for vulkan etc are in project settings) i am at a loss.

hope this helps

damnit so sorry I don’t know how to use the replies or lists properly.

Hello ,

I ran a few tests and I am not seeing the same results. Would it be possible for you to provide a same project that reproduces this issue so that I am make sure that we are on the same page?

Hello ,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will follow up.


Ok ill dig up the project and post link here… gimme a day. Thanks Rudy…

Got held up will try and get this posted tonight…

sorry for delay