[Bug] Playing a Level Sequence from Blueprint, not starting at zero (UE-51085)

To test out the playback of a Level Sequence from Blueprint, I have an empty level with a trigger volume, and a Level Sequence with a simple camera move. The movie plays back, but never plays back from the same start time. After some digging, we’ve discovered what I believe is a bug in the blueprint nodes.

When the “Make MovieSceneSequencePlaybackSettings” node is connected to my “Create Level Sequence Player”, the bug is that the settings are actually different from what is specified. In my blueprint, the “Random Start Time” value is unchecked, as pictured:

However, when I play the game and the sequence is running, I can select the Level Sequence actor, and see in its settings that the “Random Start Time” is turned on:

To test it the other way, when I then delete the “Make MovieSceneSequencePlaybackSettings” from the blueprint, and play the game again, the “Random Start Time” is unchecked on the actor and the scene plays correctly.

I believe I am setting this up correctly, but please correct me if I’m wrong. Otherwise can this be entered in as a bug for Unreal? Thank you.

EDIT: Adding tag for bug UE-51085


Thank you for bringing this to our attention, it looks like there are other issues with the Make MovieSceneSequencePlaybackSettings as well. I have gone ahead and logged one of the problems with it and made a note that most of the nodes are not functioning as intended(including the one you have mentioned above). If you would like to keep an eye on it, here is a link to the public tracker. If you have any other questions regarding this thread, feel free to reply here.

-Thank you

Thank you! I’ll keep an eye on UE-50701.

Hello Ridley R, checking up on the public tracker link you provided, I see the issue was mark as “resolved” and “by design”. The issue in that link is not exactly the one I brought up here, but it may be related. The issue I state above basically means it is impossible to keep a scene starting from a random start time, even when using a checkbox specifically stating otherwise. This essentially makes the “create level sequence player” node useless for most cases and seems like a serious issue.

Is there any way to make a bug report specifically for this issue, and make sure the issue is understood correctly by the engineers? Would it help if I provided a scene file? Thank you.


I have gone ahead and logged the other bug as you mentioned, and you can see that here in the public tracker. Also, I have made it so the developer notes are available for you to see on the link above, so the reasoning as to why it was marked by design is explained more thoroughly. If you have any other questions regarding this thread, feel free to reopen it and I will get back to you.

-Thank you

Thanks, that’s great. I see the new bug was marked as “duplicate”? Is that referring to 50701 or something else? Does that again mean it won’t get looked at?

There is another bug that has been logged that uses the same blueprints. It looks like a similar issue. Here is the public link for that log as well.

-Thank you

Hi, i have same problem at 4.19, i try to pass argument without struct, but problem persist

Hi, i found a simple trick. If you have a source code version of Unreal Engine, you can modify this line on file “MovieSceneSequencePlayer.cpp” (you found it on “Engine/Source/Runtime/MovieScene/Private” folder):

TimeCursorPosition = PlaybackSettings.bRandomStartTime ? FMath::FRand() * 0.99f * GetLength() : FMath::Clamp(PlaybackSettings.StartTime, 0.f, GetLength());

with this one:

TimeCursorPosition = FMath::Clamp(PlaybackSettings.StartTime, 0.f, GetLength());

and Rebuild the source.

With this replace, you lost the “Settings Random Start Time” pin from “Create Level Sequence Player” node:


no problem, you can reproduce it via Blueprint in a simple way, you can connect a "Random Float In Range" node to "Settings Start Time" pin: