[Bug] Metal API destroys iOS textures

If I leave Metal rendering enabled in the iOS project settings, there is an unpredictable gamble that it will mutilate some tiling textures. Sometimes the textures will become stretched into oblivion, which often happens at the edge of the first “tile”, as if the texture was set to clamp or something. On some objects there are no problems, while the same texture is awful on others. Most models I use have UVs that extend beyond the 0-1 space, but I found no connection between object UVs and the disaster areas.

Examples below:

  1. one square of okay wood texture on the table, while the rest and the coffee table are smeared.
  2. A very strange pattern of my wood texture on the wall. Notice the missing white tiles on the side as well
  3. Using stripes to trouble shoot.

A crazy thing: the third image is actual running in Metal, but what I did to fix the material was use a blank 2x2 normal map in the material. What??? I can provide material screenshots if you want, but these are all very simple mats with a texture and a texture coordinate that sets the amount of tiling (tried the texture sample AND Custom UVs).

If it doesn’t do this giant smearing thing, then there is an unexplainable stretched noise in part of the normal maps of these textures, making everything generally unusable.

These screenshots are from my iPad Air.

Hey ,

Thank you for bringing this to our attention. We are currently working on this issue and will have a response for you hopefully soon. If an issue is found, we will report the issue to for our developers to review.

Thank you and have a nice day!

uhhhhh, what?

You said you were looking for a solution. So does this mean that it has been submitted as an actual issue, because this is obviously still a problem.

Hey ,

Thanks for your patience, so this issue has been looked into further. There are currently no reports out on metal API. This issue I am still looking into, I am hoping to have an answer for you shortly.

In the meantime, have you tried this out on 4.9 Preview 4 yet?


Hey ,

UE-20174 is the entered for this stretching issue with Metal API. Unfortunately I wasn’t able to check it with the A8 Metal API due to the feature not being fully complete in Source. If you have any further questions regarding this bug, or you’d like an update, please feel free to reply back and we’ll update you.

Thank you and have a nice day!

Thank you. I haven’t tested on 4.9 preview.
I would love an update when there is any extra info on this bug.

I’ll update you when I close the bug out. However if you don’t hear from us for a while, feel free to check in. :slight_smile: