Bug: Join Session Node not working for Android

As the user aussieburger found out, the Join Session Blueprint node is not working for Android (maybe for more platforms). It seems that the ip address is not correctly handed over, so the problem lies more specifically at the Find Sessions node. An Android host can be joined by an Android client by executing the command “open [ip address of android device to join]”.

To reproduce this bug try to connect to an Android host with whatever client using the Find Sessions and Join Session nodes.
Workaround: avoid the join session session node by connecting to an android host with hard coded ip address using the excecute command node “open [ip address of android device to join]” like described above.

Please Epic, take care of this bug!

Thanks for creating the bug ticket XNAShaker - I can provide additional info if required - would really like this bug fixed for a co-op gearvr project!

PS: This pull request worked for me:
https://github.com/EpicGames/UnrealEngine/pull/1820

Hey Aussieburger, Thanks for posting the link to the pull, unfortunately it is 404

That means you’re either not logged into github and/or haven’t linked your account: Unreal Engine 4 on GitHub - Unreal Engine

I was also facing same issue on unreal engine 4.15. After doing some research I found this was a bug at Unreal engine side and was reported by community. It has been solved in 4.16 release build.