Download

Bug/Issue – Tiled Landscape: The layer File size does not match the current landscape extent

Hi guys,

I have issues with importing Material texture layers in UE4 world composition.
I’m making a tiled world in World Machine made with more than 240 tiles, then I export 3 tiles 2017x2017 to UE4 to test my map

http://i.imgur.com/wEKoUlF.png

When exporting the Tiles UE4 see them as 2017x2017 and everything till now is fine.

http://i.imgur.com/dqrQKXr.jpg

The problem starts when I create a material and try to import texture layers

http://i.imgur.com/vnnahnh.png

1st I get an error that the imported layer have low resolution than the landscape even if my landscape was imported as 2017 tiles

http://i.imgur.com/W1Ia3oq.png

And this will result on a stretched layer from the top side and not in the right place as you can see here

http://i.imgur.com/dvP73dl.png

When I check the landscape resolution I find that UE4 changed it to 4033 even if I imported it as 2017

http://i.imgur.com/Puoa1uc.jpg

I tried to change my layer texture size from 2017 to 4033 in photoshop hoping this will fix the issue, I don’t receive any error anymore about unmatched resolution but after I apply it I can see its clearly bigger than my tile and don’t apply correctly.

http://i.imgur.com/cXpvVTz.png

Tried to rebuild the tiles as 4017 reso but once imported UE4 will turn the end resolution this time to 8k, so i’m stuck in this loop.
Anyone experienced this problem and can advise how to fix this issue? Thanks.
Here is a link to the tiles and layers I used if someone want to test it.
https://1drv.ms/f/s!AmWQfzOOu29vlAuE14bdfrXGsNJk
PS: when tiles are imported they will be in the right side of the world composition window

Your WM setup shows that your final world size is 44km x 44km, that’s about 1936 square kilometers. Did you intentionally set it up like that?

The final world size in WM is calculated:1 tile resolution x tiles per side, 2017 x 22 tiles = 44374.
For now i just use 20 tiles per side for testing, the final will be around 60 km to 120 km, basically 30 to 50 tiles per side (still need to play in some tiles to confirm how big the world will be)
Is that affect how UE4 view each tile resolution ?

I solved the issue by unloading all tiles and loading only one tile at time when i apply the layer material, seems UE4 sees the overall resolution instead of the tile resolution when importing layers.
Epic should fix this bug.