Bug: invalid lightmap settings for all except first mesh in FBX

if you import a multi-mesh FBX, you will get a bug for all the meshes except the first one. You get teh invalid lightmap overlay for all meshes except the first even though the UVs are fine.


You can fix that by setting the right UV channel for lightmapping in the Details panel of static mesh editor.

Ya I just reload the mesh part and it shows up fine. Nevertheless it’s a bug

actually, I just tried that and it doesn’t work for me. So I have to reimport. Might be a Mac only issue.

I get this bug too. Very annoying.

My fix has been easy enough. Save everything. Quit UE4. Restart UE4. Load your level. Lightmaps have now magically fixed themselves.

Definitely a bug.

I’m using Maya 2015, exporting as FBX v2014, importing into UE4.2 on Windows 7 64bit.

Hi cgbeige -

I would like to look into this issue for you, but I was wondering if you could place your asset back on Dropbox for us to test? I am currently unable to reproduce with assets I have on hand.

Thank You

Eric Ketchum

I don’t have that file on hand currently but it should happen with any multi-part FBX

Well it looks like this bug is a little…spooky.

When I read Eric’s request for a file that makes the problem happen, I thought I’d go make him one.

But when I try to reproduce the issue using the same assets in the same scene that was screwing up for me endlessly yesterday - nothing, just perfect behavior again and again. Can’t make the bug happen at all.



Hi cgbeige -

I finally got this to reproduce accurately and it is a bug which I have reported. For all though, make sure that you have setup your UV unwraps correctly and that you have set the Light Map Coordinates to the correct setting.

Thank you for your help tracking this problem -

Eric Ketchum

Has this bug been fixed? I have the same issue and it fixes by restarting the editor. However it is extremely tedious to restart the editor each time I get a new model.

I found the problem. And it’s very simple. first you need to open the settings of your project> render> activate the option: Generate Mesh Distance fields. After that, open skeletal mesh (FBX) or obj> General Settings> also enable the option for this mesh: Generate Mesh Distance fields, after this save and you can already see that the watermark disappeared and the material rendered correctly.